Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#68833 - [docker] Version modified by Arch packaging causes issues in other projects

Attached to Project: Community Packages
Opened by Sergio Conde (skgsergio) - Thursday, 03 December 2020, 14:49 GMT
Last edited by Morten Linderud (Foxboron) - Saturday, 05 December 2020, 15:57 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Morten Linderud (Foxboron)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
In Arch's PKGBUILD the version is being set to `VERSION=$pkgver-ce` which breaks other projects that checks the version through the API.

I don't know if I'm missing the reason behind Arch adding the "-ce" tag to the version when upstream already ships a valid value for `VERSION`.

Additional info:
* Package version: 1:19.03.14-1

Steps to reproduce:
* Run `docker version` (or use the API, example: `python -c 'import docker; client = docker.from_env(); print([f"""{c["Name"]}: {c["Version"]}""" for c in client.version()["Components"]])'`)
* You will get '19.03.14-ce' as Engine version.

Expected:
* The API returns '19.03.14'
This task depends upon

Closed by  Morten Linderud (Foxboron)
Saturday, 05 December 2020, 15:57 GMT
Reason for closing:  Fixed
Additional comments about closing:  1:19.03.14-2
Comment by frost work (frostwork) - Saturday, 05 December 2020, 15:18 GMT
I can confirm this issue. It at least breaks Home Assistant compatibility and sets the installation into unhealthy state
because the Docker environment is not working properly as of "Running an unsupported Docker version".
Please fix this issue, as it has no obvious use anyway.
(related issue https://github.com/home-assistant/supervisor/issues/2334)
Edit: Of course home assistant fixing their version check glitch would work fine as well.
I assume "-ce" is more a docker license "solution" (mess) than an Arch idea.
Comment by frost work (frostwork) - Saturday, 05 December 2020, 15:54 GMT
Looks like upstream is not interested in fixing their version check (or better say it is on purpose)
https://github.com/home-assistant/supervisor/issues/1815

Loading...