Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#68832 - [systemd] Failed to migrate controller cgroups

Attached to Project: Arch Linux
Opened by Robert (robson) - Thursday, 03 December 2020, 11:16 GMT
Last edited by Christian Hesse (eworm) - Wednesday, 21 April 2021, 12:05 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Christian Hesse (eworm)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 8
Private No

Details

Description:
After yesterday's update systemd to version 247.1-1 after entering journalctl -b in the console, it receives such a message
systemd[448]: -.slice: Failed to migrate controller cgroups from /user.slice/user-1000.slice/user@1000.service, ignoring: Permission denied


Additional info:
* package version(s)
* config and/or log files etc.
* link to upstream bug report, if any

Steps to reproduce:
This task depends upon

Closed by  Christian Hesse (eworm)
Wednesday, 21 April 2021, 12:05 GMT
Reason for closing:  Fixed
Additional comments about closing:  systemd 248-1
Comment by loqs (loqs) - Friday, 04 December 2020, 00:01 GMT
Forum thread related to the warning [1].

[1] https://bbs.archlinux.org/viewtopic.php?id=261330
Comment by Robert (robson) - Friday, 04 December 2020, 10:31 GMT
@loqs But where to add this parameter?
systemd.unified_cgroup_hierarchy=true
Comment by loqs (loqs) - Friday, 04 December 2020, 11:43 GMT Comment by Robert (robson) - Tuesday, 08 December 2020, 00:00 GMT
Indeed, after adding this entry
GRUB_CMDLINE_LINUX_DEFAULT="loglevel=3 systemd.unified_cgroup_hierarchy=true"
in /etc/default/grub fixes it.
Comment by toma (Toma) - Tuesday, 08 December 2020, 21:48 GMT
Unfortunately, I have the following error with your suggestion: cgroup2: Unknown parameter 'memory_recursiveprot'.
Do any of you have an idea about this?

Comment by Robert (robson) - Tuesday, 08 December 2020, 22:55 GMT
And did you reload it after the GRUB edition?
grub-mkconfig -o /boot/grub/grub.cfg
Comment by toma (Toma) - Wednesday, 09 December 2020, 08:15 GMT
Indeed I did reload it after the GRUB edition.
Could it be a compatibility issue with the kernel I am using (5.4.81 LTS)?
Comment by Robert (robson) - Wednesday, 09 December 2020, 11:29 GMT
It looks like this bug appears only in linux-lts, I installed this kernel for a testand I got this bug
kernel: cgroup2: Unknown parameter 'memory_recursiveprot'
kernel: proc: Bad value for 'hidepid'
Comment by Toolybird (Toolybird) - Friday, 01 January 2021, 20:32 GMT
Heads Up:

Debian have recently switched to cgroup v2 by default [1]. It appears Fedora did same in Oct '19.

If/when it works on LTS kernel then maybe Arch should follow suit.

[1] https://salsa.debian.org/systemd-team/systemd/-/commit/170fb124a32884bd9975ee4ea9e1ffbbc2ee26b4
Comment by loqs (loqs) - Friday, 01 January 2021, 21:17 GMT
Perhaps both the initial issue and the issue with cgroup2 and linux-lts should be reported upstream.
Comment by edac val (edacval) - Monday, 22 March 2021, 10:45 GMT Comment by Christian Hesse (eworm) - Monday, 22 March 2021, 10:52 GMT
Feel free to test systemd 248rc4 from testing...
Comment by Robert (robson) - Monday, 22 March 2021, 11:11 GMT
Indeed, in version 248, the cgroups error disappeared.

Loading...