FS#6875 - kernel 2.6.21 showstoppers

Attached to Project: Arch Linux
Opened by Tobias Powalowski (tpowa) - Wednesday, 11 April 2007, 05:25 GMT
Last edited by Tobias Powalowski (tpowa) - Saturday, 05 May 2007, 15:50 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture All
Severity Critical
Priority Normal
Reported Version 0.8 Voodoo
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


Now in testing 2.6.21 series

Summary of 2.6.21 showstoppers:
- kqemu seems to be broken, works as buggy as usual, see comment below
- xfce4 battery meter seems broken (please confirm)
- ivtv is not building, fixed :D
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Saturday, 05 May 2007, 15:50 GMT
Reason for closing:  Fixed
Comment by Corrado Primier (bardo) - Monday, 16 April 2007, 23:00 GMT
Same for me (xfce battery). It constantly shows "50%%"...
Comment by Corrado Primier (bardo) - Monday, 16 April 2007, 23:01 GMT
Oh, yeah, I'm so stupid I didn't even check. The battery problem is there with 2.6.20, too, so it should be unrelated.
Comment by Corrado Primier (bardo) - Thursday, 19 April 2007, 09:53 GMT
Did you verify you loaded the 'battery' module before starting xfce? This solves the problem for me, I think it's related to acpi's modularization.
Comment by Thomas Bächler (brain0) - Sunday, 29 April 2007, 08:32 GMT
kqemu looks fine here, at least as fine as it always was. it is still slow and unreliable, but that is no news.
Comment by Attila (attila) - Monday, 30 April 2007, 07:08 GMT
On my second pc which have an internal sis900 network card (Elitegroup K7S5A) the system crashed after mounting nfs volumes. The only info what i have found is this thread


I am not a programmer so i can't say what is the problem. The only thing what i can say is that it could be a good idea that one who understand more than mine should read the link above. Background is that instead the sis900 driver is longer in the kernel it got rewritten in this release.
Comment by Jason Chu (jason) - Monday, 30 April 2007, 18:23 GMT
My usb keyboard has a lot more trouble with 2.6.21. Sometimes it decides to ignore certain keys. If it's ignoring a key, usually it takes a while to see the key again (if I move the keyboard over to another machine, I have no problems. I've never seen this problem with 2.6.20.

I would like to mention tha bardo's xfce battery issue with 2.6.20 was that his battery module wasn't loaded. With the battery module loaded in 2.6.21 xfce's battery monitor still doesn't work.

And in response to brain0, kqemu has worked fine for me with windows and linux guests up until 2.6.21. With 2.6.21, windows seems to still work, but I can't get arch to boot. It gets hung up on hwdetect (even if I disablehooks= it).
Comment by Tobias Kieslich (tobias) - Monday, 30 April 2007, 20:32 GMT
xfce4-battery-plugin is "patched" and shall work with both 2.6.20 and 2.6.21
it's in testing:wq
Comment by Jakub Schmidtke (tanis) - Monday, 30 April 2007, 23:47 GMT
I am not sure if this is the correct place to ask this, but would it be possible for default arch config for 2.6.21 to include asus-laptop driver (new) instead of asus_acpi driver (old, but still present)? The new one is way nicer than the old one...
Comment by Dawid Wróbel (cromo) - Tuesday, 01 May 2007, 14:43 GMT
Not sure about wherer it's 2.6.21 issue. It's too much hassle for me ATM to check 2.6.20 for this problem, but I never noticed it before (or vwmare never did, actually), so I'll give it a try:
504:cromo@kromka:~$ sudo modprobe rtc
FATAL: Error inserting rtc (/lib/modules/2.6.21-ARCH/kernel/drivers/char/rtc.ko): Input/output error

Comment by Attila (attila) - Tuesday, 01 May 2007, 16:08 GMT
There is a new RTC framework driver for CMOS RTCs (see Documentation/rtc.txt in the sources). For me at example a "lsmod | grep rtc" shows this:
rtc_cmos 7060 0
rtc_core 7428 1 rtc_cmos
rtc_lib 3200 1 rtc_core
Comment by Dawid Wróbel (cromo) - Tuesday, 01 May 2007, 16:10 GMT
Right, I noticed that before, but there is no /dev/rtc anyway. Is this an udev issue?
Comment by Attila (attila) - Tuesday, 01 May 2007, 16:50 GMT
There be three rtc to get informations in sysfs, proc and dev. For having /dev/rtc you need to do a "modprobe rtc_dev". udev would be nice but i don't know how to test if the necessary rtc modules runs.
Comment by Tobias Powalowski (tpowa) - Tuesday, 01 May 2007, 16:54 GMT
thanks i'll check that possibility shouldn't be too hard to add
Comment by Jason Chu (jason) - Thursday, 03 May 2007, 16:49 GMT
I'm starting to believe my usb keyboard problem is actually in the hardware. If no one else reports anything, you can assume that it's just my keyboard.
Comment by Tobias Powalowski (tpowa) - Thursday, 03 May 2007, 19:40 GMT
sis900 module should be fixed with 21.1-6 package
rtc modules are now loaded by udev 110-2
lenovo realtek sound should work now too.
Comment by Attila (attila) - Thursday, 03 May 2007, 21:45 GMT
The sis900 patch solves my problem on the other pc. Thanks a lot.
Comment by Jakub Schmidtke (tanis) - Saturday, 05 May 2007, 11:44 GMT
I tried 2.6.21-arch, and every second or so I get "usb 5-7: reset high speed USB device using ehci_hcd and address 6", so after a while my dmesg is full of that warnings. Always the same address. It is small OLED display built-in Asus G1 laptop which is not supported at all. With 2.6.19 there was no such warning.

Another thing is cpufreq is not working on core2duo. This is known bug (http://bugzilla.kernel.org/show_bug.cgi?id=7578) and there is a patch for that, but as it is because of buggy BIOS it won't come into mainline. Would it be possible to include the patch (http://bugzilla.kernel.org/attachment.cgi?id=9950) in Arch version of the kernel? With that patch I get the same frequency on the list of frequencies returned by cpufreq-info, but at least I am able to use it. Without that patch speedstep_centrino driver doesn't load so cpufreq doesn't work.
Comment by Tobias Powalowski (tpowa) - Saturday, 05 May 2007, 14:02 GMT
added core2duo fix to new kernel package
Comment by Tobias Powalowski (tpowa) - Saturday, 05 May 2007, 15:50 GMT
please open new bugs, if any is found ;), kernel moved to current.