Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#68747 - [firefox] Cannot compile with rust 1.48

Attached to Project: Arch Linux
Opened by Tomas Volf (gray_-_wolf) - Wednesday, 25 November 2020, 22:29 GMT
Last edited by Jan Alexander Steffens (heftig) - Friday, 27 November 2020, 04:00 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Jan Alexander Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Cannot compile firefox package as it is in the repositories. It starts to
work after downgrading to rust 1.47. Another way to work around the issue
seems to be commenting out --enable-rust-simd in the mozconfig. I assume
that has runtime performance implication. I do not know enough about rust
to be able to debug this further.

Additional info:
* package version(s)
current firefox, 83.0
rust 1.48
* config and/or log files etc.

0:14.70 error[E0432]: unresolved import `crate::arch::x86_64::__m64`
0:14.70 --> /home/wolf/devel/gecko-dev/third_party/rust/packed_simd/src/api/into_bits/arch_specific.rs:51:15
0:14.70 |
0:14.70 51 | $($arch_ty),*
0:14.70 | ^^^^^^^^ no `__m64` in `arch::x86_64`
0:14.70 ...
0:14.70 86 | / impl_arch!(
0:14.70 87 | | [x86["x86"]: __m64], [x86_64["x86_64"]: __m64],
0:14.70 88 | | [arm["arm"]: int8x8_t, uint8x8_t, poly8x8_t, int16x4_t, uint16x4_t,
0:14.71 89 | | poly16x4_t, int32x2_t, uint32x2_t, float32x2_t, int64x1_t,
0:14.71 ... |
0:14.71 96 | | test: test_v64
0:14.71 97 | | );
0:14.71 | |__- in this macro invocation
0:14.71 |
0:14.71 = note: this error originates in a macro (in Nightly builds, run with -Z macro-backtrace for more info)
0:14.71 error[E0432]: unresolved import `crate::arch::x86_64::_mm_movemask_pi8`
0:14.71 --> /home/wolf/devel/gecko-dev/third_party/rust/packed_simd/src/codegen/reductions/mask/x86/sse.rs:47:21
0:14.71 |
0:14.71 47 | use crate::arch::x86_64::_mm_movemask_pi8;
0:14.71 | ^^^^^^^^^^^^^^^^^^^^^----------------
0:14.72 | | |
0:14.72 | | help: a similar name exists in the module: `_mm_movemask_epi8`
0:14.72 | no `_mm_movemask_pi8` in `arch::x86_64`
0:14.72 |
0:14.72 ::: /home/wolf/devel/gecko-dev/third_party/rust/packed_simd/src/codegen/reductions/mask.rs:41:1
0:14.72 |
0:14.72 41 | impl_mask_reductions!(m8x8);
0:14.72 | ---------------------------- in this macro invocation
0:14.72 |
0:14.72 = note: this error originates in a macro (in Nightly builds, run with -Z macro-backtrace for more info)
0:14.72 error[E0432]: unresolved import `crate::arch::x86_64::_mm_movemask_pi8`
0:14.73 --> /home/wolf/devel/gecko-dev/third_party/rust/packed_simd/src/codegen/reductions/mask/x86/sse.rs:62:21
0:14.73 |
0:14.73 62 | use crate::arch::x86_64::_mm_movemask_pi8;
0:14.73 | ^^^^^^^^^^^^^^^^^^^^^----------------
0:14.73 | | |
0:14.73 | | help: a similar name exists in the module: `_mm_movemask_epi8`
0:14.73 | no `_mm_movemask_pi8` in `arch::x86_64`
0:14.73 |
0:14.73 ::: /home/wolf/devel/gecko-dev/third_party/rust/packed_simd/src/codegen/reductions/mask.rs:41:1
0:14.73 |
0:14.74 41 | impl_mask_reductions!(m8x8);
0:14.74 | ---------------------------- in this macro invocation
0:14.74 |
0:14.74 = note: this error originates in a macro (in Nightly builds, run with -Z macro-backtrace for more info)
0:14.74 error[E0432]: unresolved import `crate::arch::x86_64::_mm_movemask_pi8`
0:14.74 --> /home/wolf/devel/gecko-dev/third_party/rust/packed_simd/src/codegen/reductions/mask/x86/sse.rs:47:21
0:14.74 |
0:14.74 47 | use crate::arch::x86_64::_mm_movemask_pi8;
0:14.74 | ^^^^^^^^^^^^^^^^^^^^^----------------
0:14.75 | | |
0:14.75 | | help: a similar name exists in the module: `_mm_movemask_epi8`
0:14.75 | no `_mm_movemask_pi8` in `arch::x86_64`
0:14.75 |
0:14.75 ::: /home/wolf/devel/gecko-dev/third_party/rust/packed_simd/src/codegen/reductions/mask.rs:47:1
0:14.75 |
0:14.75 47 | impl_mask_reductions!(m16x4);
0:14.75 | ----------------------------- in this macro invocation
0:14.75 |
0:14.75 = note: this error originates in a macro (in Nightly builds, run with -Z macro-backtrace for more info)
0:14.75 error[E0432]: unresolved import `crate::arch::x86_64::_mm_movemask_pi8`
0:14.75 --> /home/wolf/devel/gecko-dev/third_party/rust/packed_simd/src/codegen/reductions/mask/x86/sse.rs:62:21
0:14.75 |
0:14.75 62 | use crate::arch::x86_64::_mm_movemask_pi8;
0:14.75 | ^^^^^^^^^^^^^^^^^^^^^----------------
0:14.75 | | |
0:14.75 | | help: a similar name exists in the module: `_mm_movemask_epi8`
0:14.75 | no `_mm_movemask_pi8` in `arch::x86_64`
0:14.75 |
0:14.75 ::: /home/wolf/devel/gecko-dev/third_party/rust/packed_simd/src/codegen/reductions/mask.rs:47:1
0:14.75 |
0:14.75 47 | impl_mask_reductions!(m16x4);
0:14.76 | ----------------------------- in this macro invocation
0:14.76 |
0:14.76 = note: this error originates in a macro (in Nightly builds, run with -Z macro-backtrace for more info)
0:14.76 error[E0432]: unresolved import `crate::arch::x86_64::_mm_movemask_pi8`
0:14.76 --> /home/wolf/devel/gecko-dev/third_party/rust/packed_simd/src/codegen/reductions/mask/x86/sse.rs:47:21
0:14.76 |
0:14.76 47 | use crate::arch::x86_64::_mm_movemask_pi8;
0:14.76 | ^^^^^^^^^^^^^^^^^^^^^----------------
0:14.76 | | |
0:14.76 | | help: a similar name exists in the module: `_mm_movemask_epi8`
0:14.76 | no `_mm_movemask_pi8` in `arch::x86_64`
0:14.76 |
0:14.76 ::: /home/wolf/devel/gecko-dev/third_party/rust/packed_simd/src/codegen/reductions/mask.rs:52:1
0:14.76 |
0:14.76 52 | impl_mask_reductions!(m32x2);
0:14.76 | ----------------------------- in this macro invocation
0:14.76 |
0:14.76 = note: this error originates in a macro (in Nightly builds, run with -Z macro-backtrace for more info)
0:14.76 error[E0432]: unresolved import `crate::arch::x86_64::_mm_movemask_pi8`
0:14.76 --> /home/wolf/devel/gecko-dev/third_party/rust/packed_simd/src/codegen/reductions/mask/x86/sse.rs:62:21
0:14.76 |
0:14.76 62 | use crate::arch::x86_64::_mm_movemask_pi8;
0:14.76 | ^^^^^^^^^^^^^^^^^^^^^----------------
0:14.76 | | |
0:14.76 | | help: a similar name exists in the module: `_mm_movemask_epi8`
0:14.76 | no `_mm_movemask_pi8` in `arch::x86_64`
0:14.77 |
0:14.77 ::: /home/wolf/devel/gecko-dev/third_party/rust/packed_simd/src/codegen/reductions/mask.rs:52:1
0:14.77 |
0:14.77 52 | impl_mask_reductions!(m32x2);
0:14.77 | ----------------------------- in this macro invocation
0:14.77 |
0:14.77 = note: this error originates in a macro (in Nightly builds, run with -Z macro-backtrace for more info)
0:14.79 Compiling fxhash v0.2.1
0:15.02 Compiling base64 v0.10.1
0:16.13 Compiling dns-parser v0.8.0
0:19.10 Compiling rustc-hash v1.0.1
0:19.23 Compiling tokio-current-thread v0.1.6
0:20.66 Compiling tokio-timer v0.2.11
0:20.77 Compiling num-traits v0.2.10
0:23.17 Compiling crossbeam-utils v0.7.0
0:24.54 Compiling aho-corasick v0.7.6
0:29.78 Compiling libdbus-sys v0.1.5
0:30.01 Compiling nom v5.1.1
0:32.01 Compiling memoffset v0.5.1
0:32.42 Compiling gkrust-shared v0.1.0 (/home/wolf/devel/gecko-dev/toolkit/library/rust/shared)
0:32.83 Compiling bindgen v0.53.2
0:32.85 Compiling fluent-langneg v0.13.0
0:33.60 Compiling intl_pluralrules v7.0.0
0:35.28 Compiling gl_generator v0.14.0
0:36.57 Compiling generic-array v0.12.0
0:36.65 error: aborting due to 7 previous errors
0:36.65 For more information about this error, try `rustc --explain E0432`.
0:36.68 error: could not compile `packed_simd`

Steps to reproduce:

Try to build firefox package on up-to-date archlinux machine.
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Friday, 27 November 2020, 04:00 GMT
Reason for closing:  Fixed
Additional comments about closing:  firefox 83.0-2
Comment by Jan de Groot (JGC) - Thursday, 26 November 2020, 09:24 GMT
Upstream bug:
https://bugzilla.mozilla.org/show_bug.cgi?id=1667736

Also affects thunderbird and js/spidermonkey.

Loading...