Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#68716 - virtualbox-guest-utils is missing mount.vboxsf command

Attached to Project: Community Packages
Opened by vyacheslav (galdralag) - Monday, 23 November 2020, 11:45 GMT
Last edited by Doug Newgard (Scimmia) - Monday, 23 November 2020, 15:40 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Virtualbox (in virtual machine) shared folder may be mounted using 2 commands:
mount -t vboxsf folder /path
or
mount.vboxsf folder /path

When running manually both commands works.
When running from systemd service only "mount.vboxsf" works (mount -t vboxsf - does not work).

Steps to reproduce:
- Copy "mount.vboxsf" from another virtual machine to test VM.

- Create shared folder for virtual machine.

- In virtual machine create systemd test.service:

[Unit]
Description=test
After=network.target

[Service]
Type=forking
ExecStart=/etc/vbmount
TimeoutSec=0
RemainAfterExit=yes

- Create /etc/vbmount:
#!/bin/bash
modprobe vboxsf
sleep 1
mount -t vboxsf folder /mnt
#mount.vboxsf folder /mnt

- Try starting service (systemctl start test.service).
When in script 'mount' command folder is not mounted.
When in script 'mount.vboxsf' command folder is mounted.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Monday, 23 November 2020, 15:40 GMT
Reason for closing:  Not a bug
Additional comments about closing:  mount.vboxsf hasn't been required for a long time now

Loading...