Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#68712 - [libxkbcommon-x11] qt5 applications crash after update to 1.0.2

Attached to Project: Arch Linux
Opened by David Rubio Escares (Kodehawa) - Sunday, 22 November 2020, 22:16 GMT
Last edited by Antonio Rojas (arojas) - Wednesday, 25 November 2020, 06:29 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Using any macro key I use on my mouse on any qt application will cause an instant crash after libX11 was updated to 1.7.
I use Paper to set the mouse macro keys, and my mouse is a Logitech G203.

Additional info:

Version:
extra/qt5-base 5.15.2-1

Log:
```
#0 0x00007f6bbc8b8615 in raise () at /usr/lib/libc.so.6
#1 0x00007f6bbc8b86a0 in <signal handler called> () at /usr/lib/libc.so.6
#2 0x00007f6bb6ead150 in () at /usr/lib/libxkbcommon-x11.so.0
#3 0x00007f6bb6eae2b4 in xkb_x11_keymap_new_from_device () at /usr/lib/libxkbcommon-x11.so.0
#4 0x00007f6bb6f8cb89 in () at /usr/lib/libQt5XcbQpa.so.5
#5 0x00007f6bb6f863cf in QXcbConnection::handleXcbEvent(xcb_generic_event_t*) () at /usr/lib/libQt5XcbQpa.so.5
#6 0x00007f6bb6f86c69 in QXcbConnection::processXcbEvents(QFlags<QEventLoop::ProcessEventsFlag>) ()
at /usr/lib/libQt5XcbQpa.so.5
#7 0x00007f6bb6faa54e in () at /usr/lib/libQt5XcbQpa.so.5
#8 0x00007f6bbcf193fc in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#9 0x00007f6bbcf21894 in QCoreApplication::exec() () at /usr/lib/libQt5Core.so.5
```

Link to upstream bug report, if any:

None, and I'm fairly sure it just needs a rebuild due to the new API of libX11 1.7 (https://lists.x.org/archives/xorg-announce/2020-November/003065.html).

Steps to reproduce:

Use a macro key on any qt application. I see this most often on KWin, but the stacktrace doesn't point to it, sans the stacktrace coming from kwin_x11.
This task depends upon

Closed by  Antonio Rojas (arojas)
Wednesday, 25 November 2020, 06:29 GMT
Reason for closing:  Fixed
Additional comments about closing:  libxkbcommon 1.0.3
Comment by David Rubio Escares (Kodehawa) - Sunday, 22 November 2020, 22:20 GMT
I've just noticed that's extra/libxkbcommon-x11, not libX11. Maybe libxkbcommon-x11 needs a rebuild instead? Not sure at this point. I've rebuilt all of my AUR packages after libx11 was bumped, so 100% sure it isn't that.
Comment by David Rubio Escares (Kodehawa) - Monday, 23 November 2020, 00:59 GMT
Actually, this actually just happened to me on latte-dock and dolphin now aswell. It also happens when I type very fast. (or spam keys)
Comment by Jan de Groot (JGC) - Monday, 23 November 2020, 10:29 GMT Comment by David Rubio Escares (Kodehawa) - Monday, 23 November 2020, 15:58 GMT
I tested 1.0.1 and it worked, so I did report it upstream at the end :)

Just didn't know where the issue was for the day or two I was getting constant crashes @_@
Comment by David Rubio Escares (Kodehawa) - Wednesday, 25 November 2020, 03:05 GMT
It's been fixed on 1.0.3 (see upstream bug report). Safe to close this bug.

Loading...