Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#68688 - [thunderbird] Language packs do not work since version 78

Attached to Project: Arch Linux
Opened by Thomas Schuetz (Murray_B) - Friday, 20 November 2020, 16:02 GMT
Last edited by Levente Polyak (anthraxx) - Monday, 11 January 2021, 22:52 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Levente Polyak (anthraxx)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
thunderbird disable sideloading since version 78, see here:
Second change from top: https://www.thunderbird.net/en-US/thunderbird/78.0/releasenotes/
https://blog.mozilla.org/addons/2019/10/31/firefox-to-discontinue-sideloaded-extensions/

This practically means that thunderbird does not load addons (XPIs) from another place
than the users thunderbird-profile. The language packs in /usr/lib/extensions are
completely useless. To get a working lang pack, it must be downloaded by the user into
their thunderbird-profile.
The packages thunderbird-i18n-* could be deleted, IMHO. It's quite irritationg to
have non-working lang packs, took me quite some time to find the reason.

BTW, the URL in the thunderbird package is wrong, it's now https://www.thunderbird.net/,
thunderbird does not belong to mozilla any longer.

Additional info:
* package version(s)
* config and/or log files etc.
* link to upstream bug report, if any

Steps to reproduce:
This task depends upon

Closed by  Levente Polyak (anthraxx)
Monday, 11 January 2021, 22:52 GMT
Reason for closing:  Fixed
Additional comments about closing:  78.6.0-3
Comment by Levente Polyak (anthraxx) - Friday, 20 November 2020, 18:05 GMT
I will fix this issue shortly, the description here is also not true, its literally just disabled by default. While that's true for some context, its certainly not an issue for a linux desktop system to install packages from trusted sources like our distro repository to a location only writable with root. If on a multi user system an attacker manages to trick a user to install anything unknown and potentially malicious, its a lost case for any other user anyway and now having side loading won't solve anything.
Comment by nordine-philippe abdessemed (npa) - Tuesday, 24 November 2020, 22:26 GMT
Hello,
I'm sure that language pack is no more necessary.
The language is set in "preferences" and a xpi file is download(see images).
Comment by Thomas Schuetz (Murray_B) - Wednesday, 25 November 2020, 04:28 GMT
Your pictures do not only show the interface to chose the language, but also to _install_ the languagepack :-) There are two possibilitys to install a language pack: The way you did it installs the pack into your home (~./thunderbird), but you formerly could also install it into the system for everybody. In linux you normally install the languagepack systemwide with a package of your distribution. Thunderbird now disabled this feature by default since version 78, but anthraxx wants to reenable it for arch so the languagepacks will work again. (I hope I got this right now...)
Comment by Jan de Groot (JGC) - Wednesday, 25 November 2020, 11:10 GMT
Config needs these two (from firefox PKGBUILD):
ac_add_options --with-unsigned-addon-scopes=app,system
ac_add_options --allow-addon-sideload

BTW, why are firefox and thunderbird PKGBUILDs completely different?

Loading...