Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#68620 - [postgresql] PLEASE ENTER SUMMARY

Attached to Project: Arch Linux
Opened by Sampson Crowley (SampsonCrowley) - Friday, 13 November 2020, 20:29 GMT
Last edited by Doug Newgard (Scimmia) - Friday, 13 November 2020, 23:43 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description: "An old version of the database was found" error on current version

/usr/bin/postgresql-check-db-dir is using v12 as old and v13 as current major version even though we're still on v12.5


Additional info:
v12.5

Steps to reproduce: Update to current version


Cause:
In /usr/bin/postgresql-check-db-dir

```
...
# PGMAJORVERSION is major version
PGMAJORVERSION=13 ***This should still be 12***
# PREVMAJORVERSION is the previous major version
PREVMAJORVERSION=12 ***This should still be 11***
...
```
This task depends upon

Closed by  Doug Newgard (Scimmia)
Friday, 13 November 2020, 23:43 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#68601   FS#68602   FS#68609 
Comment by Sampson Crowley (SampsonCrowley) - Friday, 13 November 2020, 20:31 GMT
Sorry, I accidentally hit submit before editing the title. There doesn't seem to be an edit option. It really should be an empty *required* field so new bug submitters *can't* make the mistake I just did

I would title it "check-db-dir using wrong versions"

Loading...