Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#68611 - [taskell] Launching main application fails with failure to read config.ini

Attached to Project: Arch Linux
Opened by Elias Elwyn (jthvai) - Friday, 13 November 2020, 11:17 GMT
Task Type Bug Report
Category Packages: Extra
Status Assigned
Assigned To Jelle van der Waa (jelly)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

As follows:

$ taskell
taskell: /home/user/.config/taskell/config.ini: hGetContents: invalid argument (invalid byte sequence)

This behaviour occurs both when `config.ini` is present, and absent.

The system is up to date as of 2020-11-13T17:11:10+1100. This bug was most likely caused by the `taskell` package being rebuilt to `1.10.1-37` on Arch. Between `1.10.1-36` (where the bug had not been present) and `1.10.1-37`, `haskell-mustache`, `haskell-pantry`, and `stack` had been updated on the system.
This task depends upon

Comment by Jelle van der Waa (jelly) - Friday, 13 November 2020, 11:23 GMT
I cannot reproduce the issue on taskell 1.10.1-37 on a fully updated system.
Comment by Elias Elwyn (jthvai) - Friday, 13 November 2020, 11:27 GMT
I have updated and rebooted, and the issue seems to still be there for me. I'll take a look around to see if it could be anything else on my system...

Loading...