Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#68602 - [postgresql] postgres does not start due to wrong PGMAJORVERSION in /usr/bin/postgresql-check-db-dir

Attached to Project: Arch Linux
Opened by Julian Brost (julian) - Thursday, 12 November 2020, 22:25 GMT
Last edited by Levente Polyak (anthraxx) - Friday, 13 November 2020, 08:49 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

Description:
PGMAJORVERSION in /usr/bin/postgresql-check-db-dir was increased to 13 while the package is still on version 12.

Additional info:
* package version(s): postgresql 12.5-1
* config and/or log files etc.
* link to upstream bug report, if any

Steps to reproduce:
Upgrade to postgresql 12.5-1 and try to restart postgres. It will fail with the following error message, because the ExecStartPre script thinks you have to upgrade the database to version 13 first, however the package is not yet on version 13:

postgres[803940]: An old version of the database format was found.
postgres[803940]: See https://wiki.archlinux.org/index.php/PostgreSQL#Upgrading_PostgreSQL
This task depends upon

Closed by  Levente Polyak (anthraxx)
Friday, 13 November 2020, 08:49 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#68601 
Comment by Andrej Podzimek (andrej) - Friday, 13 November 2020, 01:50 GMT
I just got caught by this. And of course, `pg_upgrade` didn't work either, because `postgresql-old-upgrade` is still at version 11. :-D (The working solution is just to ugly-hack the version number in `/usr/bin/postgresql-check-db-dir`.)
Comment by Bjoern Franke (bjo) - Friday, 13 November 2020, 08:16 GMT
Stumbled over the same and was wondering because it's no major upgrade.

Loading...