Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#68595 - [systemd-libs] should move pkgconfig files from systemd into systemd-libs

Attached to Project: Arch Linux
Opened by Jiachen Yang (farseerfc) - Thursday, 12 November 2020, 04:26 GMT
Last edited by Eli Schwartz (eschwartz) - Thursday, 12 November 2020, 11:50 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:

Currently pkgconfig files are provided by systemd package, and the corresponding so files are in systemd-libs.
```
$ pacman -Ql systemd | grep ".pc$"
systemd /usr/lib/pkgconfig/libsystemd.pc
systemd /usr/lib/pkgconfig/libudev.pc
systemd /usr/share/pkgconfig/systemd.pc
systemd /usr/share/pkgconfig/udev.pc
$ pacman -Ql systemd-libs | grep "so$"
systemd-libs /usr/lib/libsystemd.so
systemd-libs /usr/lib/libudev.so
```

Packages needing those so files would also want those pkgconfig files to build.
Maybe we should consider moving those pkgconfig files to systemd-libs?

Additional info:
* package version(s)

systemd 246.6-1
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Thursday, 12 November 2020, 11:50 GMT
Reason for closing:  Not a bug
Comment by Allan McRae (Allan) - Thursday, 12 November 2020, 05:17 GMT
All the headers are in the systemd package.
Comment by Jiachen Yang (farseerfc) - Thursday, 12 November 2020, 05:35 GMT
Right, headers are also in the systemd package.
Should we move those headers as well?
Comment by Doug Newgard (Scimmia) - Thursday, 12 November 2020, 05:39 GMT
This doesn't make a lot of sense. systemd-libs is just there to avoid dep cycles, only needed at runtime.
Comment by Jiachen Yang (farseerfc) - Thursday, 12 November 2020, 05:47 GMT
Okay, I misunderstood the reason of systemd-lib split. Thanks for clarification. Request to close this task.

Loading...