Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#68584 - [python-jsonpickle] FTBFS due to failing check

Attached to Project: Community Packages
Opened by loqs (loqs) - Tuesday, 10 November 2020, 16:26 GMT
Last edited by Eli Schwartz (eschwartz) - Tuesday, 10 November 2020, 20:02 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Felix Yan (felixonmars)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
python-jsonpickle fails to build from source as check fails due to failing a black formatting check.
Fixed by dropping use of pytest-black which is not relevant to packaging or integration testing, as has already been done for flake8.
Also drop pytest-coverage on the same basis [2].

Additional info:
* python-jsonpickle 1.4.1-3
[1] pkgbuild.log
[2] PKGBUILD.diff

Steps to reproduce:
Build package in a clean chroot.
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Tuesday, 10 November 2020, 20:02 GMT
Reason for closing:  Fixed
Additional comments about closing:  in trunk
Comment by Eli Schwartz (eschwartz) - Tuesday, 10 November 2020, 16:48 GMT
  • Field changed: Status (Unconfirmed → Assigned)
  • Field changed: Severity (Very Low → Low)
  • Task assigned to Felix Yan (felixonmars)
Thanks! I've been trying to purge the use of completely unrelated linting checks in PKGBUILD testsuites, and this just goes to show why they're bad.
Comment by loqs (loqs) - Tuesday, 10 November 2020, 17:15 GMT
 FS#68511  is another example of the issue.

Loading...