Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#68577 - [r] prepackaed library is out of date

Attached to Project: Arch Linux
Opened by Greyson Christoforo (greyltc) - Monday, 09 November 2020, 17:58 GMT
Last edited by Antonio Rojas (arojas) - Monday, 09 November 2020, 20:28 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

This package seems to bring with it a number of libraries. I'm not sure how this list is chosen, but I assume there's some good reason for these specific libraries to be built into the r package.
```
$ ls -1 /usr/lib/R/library
base
boot
class
cluster
codetools
compiler
datasets
foreign
graphics
grDevices
grid
KernSmooth
lattice
MASS
Matrix
methods
mgcv
nlme
nnet
parallel
rpart
spatial
splines
stats
stats4
survival
tcltk
tools
translations
utils
```
These libraries have their own versions which are not captured in the R package version and this can cause problems when they become out of date and then impossible to update because they're rolled into the r package that's not really totally out of date.

For example, today the version of this package is 4.0.3 and that's great because 4.0.3 is the current stable released version of R.

What's not great is that the stable release version of the KernSmooth R library is 2.23-18 (see https://cran.r-project.org/web/packages/KernSmooth/index.html ) but the KernSmooth built into this package is 2.23-17:
```
$ cat /usr/lib/R/library/KernSmooth/DESCRIPTION
Package: KernSmooth
Priority: recommended
Version: 2.23-17
Date: 2020-04-26
...
```
This can cause some real problems, like today the latest version of Bioconductor ( http://www.bioconductor.org/ ) can not be installed because it needs the very latest version of KernSmooth, 2.23-18

So how can KernSmooth be updated individually if its bundled into the core r package?

Do all these libraries really need to be bundled togehter here? Should they become dependencies that can then be updated seperately so that their versions can be properly tracked?

Is the right thing to do just flag the r package as out of date when any of these libraries become out of date and then rebuild it, bumping the release int?
This task depends upon

Closed by  Antonio Rojas (arojas)
Monday, 09 November 2020, 20:28 GMT
Reason for closing:  Not a bug
Comment by Antonio Rojas (arojas) - Monday, 09 November 2020, 19:23 GMT
Those libraries are included in the upstream tarball. If you need a more recent version, you can override them with a locally installed version.
Comment by Greyson Christoforo (greyltc) - Monday, 09 November 2020, 19:51 GMT
Ok. Thanks!

Loading...