Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#68543 - [pulseaudio] Problem with headphone

Attached to Project: Arch Linux
Opened by Obs (obspm) - Friday, 06 November 2020, 11:55 GMT
Task Type Bug Report
Category Packages: Core
Status Unconfirmed
Assigned To No-one
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 4
Private No

Details

Description:

Super weird problem with a Dell XPS 9360 where sometime ago (like 1 or 2 weeks top) everything work fine, currently when I plug a headphone I get the sound in my headphone, but the sound from the laptop still going on.

I try some alsactl restore, but no luck with that.

I put the «Severity» to «High» event it's just for the sound, but it's very very annoying in the office when you need to do a visioconf. I will of course understand if set to low

The arch are up2date

Thanks

[linux]$ pacman -Q|grep alsa
alsa-card-profiles 13.99.3-1
alsa-firmware 1.2.4-2
alsa-lib 1.2.4-3
alsa-plugins 1:1.2.2-2
alsa-topology-conf 1.2.4-2
alsa-ucm-conf 1.2.4-2
alsa-utils 1.2.4-2
pulseaudio-alsa 1:1.2.2-2
zita-alsa-pcmi 0.3.2-3
This task depends upon

2020-11-26: A task closure has been requested. Reason for request: Newer pulseaudio versions have fixed this issue. https://gitlab.freedesktop.org/pulseaudio/pulseaudio/-/issues/1043 has been closed upstream as well.
Comment by Dan (Mr.D) - Wednesday, 11 November 2020, 03:22 GMT
I have a similar probably related problem on my XPS 9360. When I plug in my headphones, the sound doesn't automatically switch anymore and I have to manually change it in the KDE audio settings.
Comment by Kevin Velásquez (kevinv23) - Sunday, 15 November 2020, 04:59 GMT
I have the same problem as Dan. I plug my headphones and the sound doesn't automatically switch. I have an inspiron 5482 running XFCE
Comment by Brett Cornwall (ainola) - Tuesday, 17 November 2020, 19:33 GMT
Since the upgrade to 13.99.3-1 I've had the following behavior:

- Unplugging a headset always results in muted output even if it was previously unmuted
- Plugging in a headset always results in muted output even if it was previously unmuted
- A plugged-in headset will have the port set to "speakers" rather than "headphones" even though pulseaudio detects that it's plugged in (and it will reproducibly never switch correctly, requiring manual intervention).

This affects two different laptop models and my desktop, so I assume this issue is universal. :)

Downgrading to {pulseaudio*,libpulse}-13.99.2+13+g7f4d7fcf5-1 resolves the problem for now. Given that the recent changes to the pulseaudio package appear to be only bumping the version, it seems that upstream has a regression. I've filed a bug report here:

https://gitlab.freedesktop.org/pulseaudio/pulseaudio/-/issues/1043
Comment by Kevin Velásquez (kevinv23) - Tuesday, 17 November 2020, 22:36 GMT
Thank you Brett for your suggestion, downgrading to 13.99.2+13+g7f4d7fcf5-1 solved my issue for now. Appreciate it.
Comment by Trit' (trit) - Saturday, 21 November 2020, 10:58 GMT
I have a similar problem since I have upgraded to PulseAudio 13.99.3+4+gd83ad6990-1: when I plug my headphones in, the sound switches on them. But it stay on “Line out (unplugged)” instead to switch back to the internal PC speakers when I plug them out. I have to manually select the speakers to have sound again.

Downgrading to 13.99.3-1 makes PA working fine again.

My computer is a HP Pavilion dv6 1140-ef with a Intel 82801I HD Audio (so says Inxi).
Comment by patrick (potomac) - Saturday, 21 November 2020, 18:13 GMT Comment by Carlos (cyberconan) - Wednesday, 25 November 2020, 20:36 GMT
Thanks, downgrading pulseaudio*, (lib32-)libpulse and alsa-card-profiles works for my MSI laptop, but I needed shutdown and power on again. Then sound works again from headphones.
We'll need wait for 14.1 version.
Comment by Trit' (trit) - Thursday, 26 November 2020, 14:51 GMT
Fixed for me with with the version 14.0. I never had to downgrade alsa-card-profiles, though.
Comment by Carlos (cyberconan) - Friday, 27 November 2020, 16:41 GMT
I removed ignored lines in pacman, pacman -Syu, shutdown, power on, cross fingers and headset sound still works with 14.0. I think MSI hardware doesn't like the change from 13.99.3+14+geaa6d5d6c to 14.0, but from 13.99.3-1 to 14.0 was well.

Loading...