Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#68490 - [gnome-shell] crash on login

Attached to Project: Arch Linux
Opened by Peter Maatman (blackwolf12333) - Sunday, 01 November 2020, 10:06 GMT
Last edited by Jan de Groot (JGC) - Thursday, 26 November 2020, 09:24 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

Gnome-shell 3.38.1 crashes after logging in with an error in the logs.

Oct 27 08:39:59 coffee gnome-shell[2505]: JS ERROR: Error: GSettings key app-picker-layout not found in schema org.gnome.shell
_checkKey@resource:///org/gnome/gjs/modules/core/overrides/Gio.js:576:23
_init/createCheckedMethod/<@resource:///org/gnome/gjs/modules/core/overrides/Gio.js:528:30
_loadPages@resource:///org/gnome/shell/ui/appDisplay.js:870:40
_init@resource:///org/gnome/shell/ui/appDisplay.js:862:14
_init@resource:///org/gnome/shell/ui/appDisplay.js:926:29
_init@resource:///org/gnome/shell/ui/viewSelector.js:180:27
_init@resource:///org/gnome/shell/ui/overviewControls.js:443:29
_init@resource:///org/gnome/shell/ui/overview.js:119:26
init@resource:///org/gnome/shell/ui/overview.js:294:26
_initializeUI@resource:///org/gnome/shell/ui/main.js:227:14
start@resource:///org/gnome/shell/ui/main.js:159:5
@<main>:1:47
Oct 27 08:39:59 coffee gnome-shell[2505]: Execution of main.js threw exception: Script <main> threw an exception

https://gitlab.gnome.org/GNOME/gnome-maps/-/issues/304 seems like a similar issue in that it is also a missing
key. The issue is closed with the reason that it is likely a packaging issue, which is why I'm reporting this here.

Additional info:
* package version(s)
gnome-shell 1:3.38.1-1
gsettings-desktop-schemas 3.38.0-1
* config and/or log files etc.
gsettings indicates the key does not exist in the org.gnome.shell schema.

Steps to reproduce:
I am not sure how to reproduce this, I have updated gnome-shell
on both my desktop and my laptop. I have no issues on my laptop
but my desktop install is showing this issue.
This task depends upon

Closed by  Jan de Groot (JGC)
Thursday, 26 November 2020, 09:24 GMT
Reason for closing:  Not a bug
Comment by Peter Maatman (blackwolf12333) - Sunday, 01 November 2020, 10:07 GMT
Workaround that works for now is to downgrade back to gnome-shell 3.36
Comment by Peter Maatman (blackwolf12333) - Wednesday, 25 November 2020, 21:21 GMT
My bad, I had schema files still laying around from a git install from a while ago. Those were placed in /usr/local/share and were read before the schemas in /usr/share.

Loading...