FS#68487 - [pulseaudio] Failed to open module module-esound-protocol-tcp.so

Attached to Project: Arch Linux
Opened by James (thx1138) - Sunday, 01 November 2020, 00:45 GMT
Last edited by David Thurstenson (thurstylark) - Friday, 11 March 2022, 14:17 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No


pulseaudio 13.99.3-1

pulseaudio[1418163]: Failed to open module module-esound-protocol-tcp.so: module-esound-protocol-tcp.so: cannot open shared object file: No such file or directory

Anything known about this?
This task depends upon

Closed by  David Thurstenson (thurstylark)
Friday, 11 March 2022, 14:17 GMT
Reason for closing:  None
Additional comments about closing:  see comments
Comment by James (thx1138) - Sunday, 01 November 2020, 01:04 GMT
Hmm - PulseAudio 13.0 release notes has "meson: Disable esound modules", but then, how is something trying to load the module?

pulseaudio 13.99.2+22+ga9c6d43b7-1 was working fine.

Comment by James (thx1138) - Sunday, 01 November 2020, 01:17 GMT

"We support EsounD only with Autotools and not with Meson. As we're going to drop Autotools, we'll either have to add EsounD support to Meson or drop the EsounD stuff entirely."
"Might be worth putting in the 14.0 release announcement to see if anyone is still dependent on this."

There does not seem to be any resolution or explanation there though.
Comment by James (thx1138) - Sunday, 01 November 2020, 02:03 GMT
Downgrading to 13.99.2+22+ga9c6d43b7-1 does not restore sound, and now gives the same error. So, it seems that something else is causing the problem, after today's upgrade.
Comment by James (thx1138) - Sunday, 01 November 2020, 02:27 GMT
Hmm - there seems to be a problem with my browser - other sound works fine with pulseaudio 13.99.3-1.

There is still the question of that error message, but it seems unimportant.

Just close this.
Comment by jl (jljljljljljl) - Sunday, 01 November 2020, 22:12 GMT
I have the same issue as James since today (applied the update to 13.99.3, Firefox renders PC completely useless after a few seconds. Need to kill Firefox. All other applications accessing PulseAudio stop working after having started to watch a video/anything that requires audio in FF. Not even a service restart helps. Workaround: do not use Firefox + anything in there that requires sound.
Comment by James (thx1138) - Tuesday, 03 November 2020, 15:19 GMT
Copied from upstream:

Tanu Kaskinen commented on a discussion:

You probably have enabled "Make discoverable PulseAudio network sound devices available locally" in paprefs. The paprefs options are stored in gsettings and read by module-gsettigns.

We should remove the esound stuff from paprefs (I didn't even know it did this before you reported this).

I tried to make a quick patch for dropping the esound stuff from paprefs, but it's less trivial than I thought, so I won't make that patch now. I'll add some todo items to the issue description.

I created a separate issue for the log message. The log message is a bug regardless of whether we drop esound or not.
Comment by Viktor (Kamey) - Thursday, 31 December 2020, 14:49 GMT
I had the same issue, any solution?
Comment by jl (jljljljljljl) - Thursday, 31 December 2020, 15:16 GMT
hi @Viktor - cf. the comment from James, this did fix the issue for me. In addition, I updated to latest stable pulseaudio + latest FF. No more issues.
Comment by Alexander Stein (AStein) - Friday, 11 March 2022, 14:16 GMT