Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#68485 - [pipewire] 0.3.14 breaks audio

Attached to Project: Arch Linux
Opened by Abdulkadir Furkan Şanlı (abdulocracy) - Saturday, 31 October 2020, 14:53 GMT
Last edited by Jan Alexander Steffens (heftig) - Tuesday, 09 February 2021, 11:49 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Jan Alexander Steffens (heftig)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No

Details

Description: Sorry for the vague summary, no idea what's really happening. Sound wasn't playing from Firefox and Telegram, probably every other application. Downgrading to 0.3.13-2 fixed it.

Logs attached.
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Tuesday, 09 February 2021, 11:49 GMT
Reason for closing:  No response
Comment by Stanislav T (stas-t) - Sunday, 01 November 2020, 19:30 GMT
For me the work-around was uninstalling pipewire-pulse and pipewire-jack packages. Before that pulseaudio was starting but wasn't functional.
I still have a problem with Cheese when pipewire is enabled, but that was also before this upgrade and isn't something new.
Comment by Stanislav T (stas-t) - Sunday, 01 November 2020, 19:34 GMT
Another small update: the issue is only present on one laptop, namely ACER Nitro 5 (AN515-42-R4QR), AMD based.
I tested on two others which are Intel - this issue doesn't occur there.
Another difference: on the Acer laptop my account belongs to these groups: network realtime users video storage lp input audio wheel.
I'm also not sure what is causing this problem.
Comment by AaronP (Bellum) - Tuesday, 03 November 2020, 09:32 GMT
Probably fixed by cherry-picking 6962c27af98c31374e8b349b8962b3b8a2b66be8
Comment by Ilya Fedin (ilya-fedin) - Saturday, 07 November 2020, 17:14 GMT
This is still valid, workaround is to change the last line of /etc/pipewire/pipewire.conf to `exec /usr/bin/pipewire-media-session -d alsa-acp,alsa-seq`
Comment by mattia (nTia89) - Tuesday, 22 December 2020, 21:43 GMT
Issue still present with new 0.3.18 version (dated 2020-12-15) ?

Loading...