Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#68471 - links: add brotli as runtime dependency

Attached to Project: Arch Linux
Opened by Alif (alive4ever) - Friday, 30 October 2020, 00:01 GMT
Last edited by Christian Hesse (eworm) - Tuesday, 14 September 2021, 14:16 GMT
Task Type Feature Request
Category Packages: Core
Status Closed
Assigned To Christian Hesse (eworm)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Brotli (RFC7932) is a widely used compression algorithm for web servers.
Since version 2.15, links has supported brotli decompression, and this
capability will be automatically enabled if brotli libraries are found
during build.

Additional info:
* package version(s): 2.21-1
* upstream changelogs: http://links.twibright.com/download/ChangeLog

Steps to reproduce:
$ ldd $(which links) | grep libbrotlidec
returns nothing, since the binary isn't linked with libbrotlidec.so
This task depends upon

Closed by  Christian Hesse (eworm)
Tuesday, 14 September 2021, 14:16 GMT
Reason for closing:  Fixed
Additional comments about closing:  links 2.24-2
Comment by Christian Hesse (eworm) - Wednesday, 21 April 2021, 12:41 GMT
Well, we would have to move brotli to [core]...
Is it worth it?

Loading...