Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#68463 - [python-inflect] Package metadata is installed with package name "root" instead of "inflect"

Attached to Project: Community Packages
Opened by Lea Waller (lea) - Thursday, 29 October 2020, 12:27 GMT
Last edited by David Runge (dvzrv) - Thursday, 05 November 2020, 10:11 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To David Runge (dvzrv)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
When I try to programmatically query the installed version of the "inflect" library, I get an error, even though importing the inflect package works without problems.
$ pacman -S python-inflect
$ python -c "import inflect" # no error
$ python -c "import importlib.metadata; print(importlib.metadata.version('inflect'))" # importlib.metadata.PackageNotFoundError: inflect

Looking at the installed files with pacman, it seems as though the egg-info is somehow installed under the package name "root" instead of "inflect".

$ pacman -Ql python-inflect
python-inflect /usr/
python-inflect /usr/lib/
python-inflect /usr/lib/python3.8/
python-inflect /usr/lib/python3.8/site-packages/
python-inflect /usr/lib/python3.8/site-packages/__pycache__/
python-inflect /usr/lib/python3.8/site-packages/__pycache__/inflect.cpython-38.opt-1.pyc
python-inflect /usr/lib/python3.8/site-packages/__pycache__/inflect.cpython-38.pyc
python-inflect /usr/lib/python3.8/site-packages/inflect.py
python-inflect /usr/lib/python3.8/site-packages/root-4.1.0-py3.8.egg-info/
python-inflect /usr/lib/python3.8/site-packages/root-4.1.0-py3.8.egg-info/PKG-INFO
python-inflect /usr/lib/python3.8/site-packages/root-4.1.0-py3.8.egg-info/SOURCES.txt
python-inflect /usr/lib/python3.8/site-packages/root-4.1.0-py3.8.egg-info/dependency_links.txt
python-inflect /usr/lib/python3.8/site-packages/root-4.1.0-py3.8.egg-info/requires.txt
python-inflect /usr/lib/python3.8/site-packages/root-4.1.0-py3.8.egg-info/top_level.txt
python-inflect /usr/share/
python-inflect /usr/share/doc/
python-inflect /usr/share/doc/python-inflect/
python-inflect /usr/share/doc/python-inflect/CHANGES.rst
python-inflect /usr/share/doc/python-inflect/CONTRIBUTING.md
python-inflect /usr/share/doc/python-inflect/README.rst
python-inflect /usr/share/licenses/
python-inflect /usr/share/licenses/python-inflect/
python-inflect /usr/share/licenses/python-inflect/LICENSE

As a result, I can query the version of the "inflect" package when I ask about the "root" package.
$ python -c "import importlib.metadata; print(importlib.metadata.version('root'))" # prints 4.1.0

If I install the package via pip instead, I do not get any error.
$ pip install --user inflect
$ python -c "import importlib.metadata; print(importlib.metadata.version('inflect'))" # prints 4.1.0

Additional info:
* package version(s)
4.1.0-1

* config and/or log files etc.
No

* link to upstream bug report, if any
This is specific to the ArchLinux package.

Steps to reproduce:
See description
This task depends upon

Closed by  David Runge (dvzrv)
Thursday, 05 November 2020, 10:11 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed with 4.1.0-2
Comment by loqs (loqs) - Thursday, 29 October 2020, 13:34 GMT
Caused by the use of dephell.
Comment by David Runge (dvzrv) - Thursday, 05 November 2020, 09:59 GMT
@lea: Thanks for the report!

Will publish a new pkgrel in a bit.

Loading...