Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#68455 - [openscenegraph] Missing (optional?) dependency on libvncserver?

Attached to Project: Arch Linux
Opened by t0rb3n (t0rb3n) - Wednesday, 28 October 2020, 19:29 GMT
Last edited by Andreas Radke (AndyRTR) - Wednesday, 21 April 2021, 11:35 GMT
Task Type Bug Report
Category Packages: Extra
Status Assigned
Assigned To Levente Polyak (anthraxx)
Architecture All
Severity Very Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

Description:

When starting Scribus, OpenSceneGraph library gets loaded, but files a warning about a missing dynamic library:

Warning: dynamic library '/usr/lib/osgPlugins-3.6.5/osgdb_vnc.so' exists, but an error occurred while trying to open it:
libvncclient.so.1: cannot open shared object file: No such file or directory

The warning disappears once the libvncserver package is installed. AFAICS, OpenSceneGraph is only needed for import of rather specialised 3D files, and the warning is non-fatal.



Additional info:
* package version openscenegraph-3.6.5-1
* The warning seems to persist for some time already, I found it in the German Arch Linux forum from 2017: https://bbs.archlinux.de/viewtopic.php?id=30294 (probably unnoticed since Scribus is mostly used in a graphical context)
* At least the Ubuntu focal package libopenscenegraph160 seems to not include osgdb_vnc.so

Steps to reproduce:
1. Have scribus installed (brings openscenegraph as a hard dependency), but not libvncserver
2. Open scribus from commandline. The above warning is filed to the terminal.
This task depends upon

Loading...