Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#68448 - [fzf] 0.24.0-1 prints empty --version

Attached to Project: Community Packages
Opened by Fnord Popos (noddy) - Tuesday, 27 October 2020, 22:44 GMT
Last edited by Morten Linderud (Foxboron) - Wednesday, 28 October 2020, 15:55 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Thore Bödecker (foxxx0)
Morten Linderud (Foxboron)
Filipe Laíns (FFY00)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:

Since 0.24.0, `fzf --version` prints nothing. This breaks the accompanying vim scripts, which check the version of the binary.

Steps to reproduce:

$ fzf --version|xxd
00000000: 0a
This task depends upon

Closed by  Morten Linderud (Foxboron)
Wednesday, 28 October 2020, 15:55 GMT
Reason for closing:  Fixed
Additional comments about closing:  0.24.0.1-1
Comment by Alex Fikl (alexfikl) - Wednesday, 28 October 2020, 00:29 GMT
Following this comment
https://github.com/junegunn/fzf.vim/issues/1150#issuecomment-717401172
it seems like the new version requires setting the version number as a build argument.
Comment by loqs (loqs) - Wednesday, 28 October 2020, 03:00 GMT
Does applying the attached diff to the PKGBUILD resolve the issue?

I passed the ldflags directly to go due to [1]. I did not remove the now unused CGO_LDFLAGS or ldflags parameter of GOFLAGS.

[1] https://github.com/golang/go/issues/38522
Comment by Rafael Cintra (rlcintra) - Wednesday, 28 October 2020, 07:12 GMT
The diff fixed the issue for me.
Comment by Fnord Popos (noddy) - Wednesday, 28 October 2020, 11:56 GMT
The diff fixes it.

Loading...