Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#68427 - qtav fails to build with Qt 5.15

Attached to Project: Arch Linux
Opened by Flaviu Tamas (flaviu) - Monday, 26 October 2020, 19:24 GMT
Last edited by Antonio Rojas (arojas) - Saturday, 18 September 2021, 21:21 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Felix Yan (felixonmars)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

QtAV does not build due to an incompatibility with qt 5.15

Additional info:
* package version(s)

qt5-base 5.15.1-3
qtav 1.13.0-1

* config and/or log files etc.

Here is the output of makepkg:

In file included from ./QtAV/Filter.h:27,
from ./QtAV/GLSLFilter.h:26,
from filter/GLSLFilter.cpp:22:
./QtAV/FilterContext.h:75:18: error: field ‘clip_path’ has incomplete type ‘QPainterPath’
75 | QPainterPath clip_path;
| ^~~~~~~~~
In file included from /usr/include/qt/QtGui/qtransform.h:43,
from /usr/include/qt/QtGui/qimage.h:48,
from /usr/include/qt/QtGui/qpixmap.h:49,
from /usr/include/qt/QtGui/qpainter.h:48,
from /usr/include/qt/QtGui/QPainter:1,
from ./QtAV/FilterContext.h:28,
from ./QtAV/Filter.h:27,
from ./QtAV/GLSLFilter.h:26,
from filter/GLSLFilter.cpp:22:
/usr/include/qt/QtGui/qmatrix.h:54:7: note: forward declaration of ‘class QPainterPath’
54 | class QPainterPath;
| ^~~~~~~~~~~~

* link to upstream bug report, if any

The bug has been fixed upstream in https://github.com/wang-bin/QtAV/commit/5263d9d9ee29303a919d33d52b15acda554226c5, but they have not done a release in a while.

There is a request for a release in https://github.com/wang-bin/QtAV/issues/1334

There's a little extra background here: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=972355

Steps to reproduce:

1. Make sure you have qt5-base 5.15+ installed
2. grab https://github.com/archlinux/svntogit-packages/blob/packages/qtav/trunk/PKGBUILD
3. makepkg
This task depends upon

Closed by  Antonio Rojas (arojas)
Saturday, 18 September 2021, 21:21 GMT
Reason for closing:  Fixed
Comment by Eli Schwartz (eschwartz) - Monday, 26 October 2020, 19:34 GMT
Seems reasonable.

BTW hello there, didn't realize you were an arch user. :D
Comment by mattia (nTia89) - Saturday, 18 September 2021, 19:11 GMT
I confirm the issue.
I must add (as stated here[1]), QTav project is no more actively maintained. It is time to think if drop it from our repo?

[1] https://github.com/wang-bin/QtAV/issues/1334
Comment by Antonio Rojas (arojas) - Saturday, 18 September 2021, 21:21 GMT
We can't drop the package as long as digikam is using it.

Loading...