Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#68423 - [python-django] python-django 3.1.2 is incompatible with python-asgiref 3.3.0 in official repo

Attached to Project: Arch Linux
Opened by simunic (simunic) - Monday, 26 October 2020, 10:22 GMT
Last edited by Jelle van der Waa (jelly) - Thursday, 29 October 2020, 12:15 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jelle van der Waa (jelly)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


python-django 3.1.2-1 requires asgiref~=3.2.10, but python-asgiref in the official repo is at version 3.3.0. Hence versions don't match and it throws an error.

Additional info:

Steps to reproduce:
I got this error while testing a new version of mathics. The traceback says:

File "/usr/lib/python3.8/site-packages/pkg_resources/", line 567, in _build_master
File "/usr/lib/python3.8/site-packages/pkg_resources/", line 884, in require
needed = self.resolve(parse_requirements(requirements))
File "/usr/lib/python3.8/site-packages/pkg_resources/", line 775, in resolve
raise VersionConflict(dist, req).with_context(dependent_req)
pkg_resources.ContextualVersionConflict: (asgiref 3.3.0 (/usr/lib/python3.8/site-packages), Requirement.parse('asgiref~=3.2.10'), {'django'})

(I report this bug as medium severity since mathics 1.1.0rc1 doesn't work because of this)
This task depends upon

Closed by  Jelle van der Waa (jelly)
Thursday, 29 October 2020, 12:15 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in 3.1.2-2
Comment by Jelle van der Waa (jelly) - Monday, 26 October 2020, 20:53 GMT
It's a dep of  FS#68363