Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#68406 - [mesa 20.2.1-1] [nouveau] NVC0 - System's frame rate spontaneously slows to a crawl

Attached to Project: Arch Linux
Opened by Lime (LimeInkling) - Saturday, 24 October 2020, 19:54 GMT
Last edited by Andreas Radke (AndyRTR) - Wednesday, 21 April 2021, 11:24 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


Sometimes, when doing anything even remotely graphics-related, my system's frame rate will slow down to <1fps. The mouse pointer will also only move a pixel or two at a time, making it impossible (if not really unpleasant) to do anything on the desktop. This problem was first noticed when playing video while multitasking, but now it just seems to do it whenever, and very frequently too.

Additional info:
* Driver: mesa 20.2.1-1
* Kernel: linux 5.9.1-arch1-1
* GPU: NVIDIA Quadro 4000

* Last time I remember not having this issue was before the upgrade to kernel 5.9, although I'm not sure if it's the kernel or the driver causing this issue.

* I understand a dmesg output would be the best thing to put here, but I don't know how to attach one using just the command-line. However, my Xorg.0.log did seem to be complaining about the effects of this issue, with messages such as:

• SteelSeries SteelSeries Rival 600: client bug: event processing lagging behind by [x]ms, your system is too slow
• SteelSeries SteelSeries Rival 600: SYN_DROPPED event - some input events have been lost.

If any more log info is needed, just drop me a comment.

Steps to reproduce:
Just have an NVIDIA Quadro 4000 (or similar) and try to do stuff on it. Honestly, I don't know.
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Wednesday, 21 April 2021, 11:24 GMT
Reason for closing:  Fixed
Comment by loqs (loqs) - Saturday, 24 October 2020, 20:38 GMT
If you downgrade the kernel package and any dependent packages can you still reproduce the issue? Which would rule out the kernel as the cause.
Similar procedure for mesa. If you downgrade mesa can you still reproduce the issue?
Comment by Lime (LimeInkling) - Sunday, 25 October 2020, 07:44 GMT
Alright, so after some testing I can conclude that the kernel is the most likely source of the problem. Alongside this weird 'freezing' bug, there are also some more minor graphical glitches when moving around windows and scrolling through webpages. These graphical bugs only stopped appearing after downgrading to linux 5.8.14-arch1-1, as even using an older mesa version (20.1.8) on the current kernel still produces these effects.

One other oddity - after the 'freezing' had taken effect, I also noticed that tty consoles I tried to switch to were invisible, although commands could still be entered into them.
Comment by loqs (loqs) - Sunday, 25 October 2020, 18:13 GMT
You could report the issue upstream. Try linux 5.10-rc1 when it is released. Bisect between 5.8 and 5.9 to find the causal commit.

When you have a fix the kernel package maintainers can consider applying it.
Comment by Trit' (trit) - Wednesday, 18 November 2020, 10:21 GMT
Same problem here since I have upgraded the kernel to 5.9.1: suddenly, the DE (XFCE) became almost unresponsive on a PC having a GeForce 210 with Nouveau too (no more Nvidia drivers for this model). I have to power off the computer and boot it again to regain a responsive system. Switching to a TTY console is impossible because the display seems frozen.
Note that the computer turns off normally (I always have managed to do a proper turn off, not a forced one), but the display stays frozen (no switch to a black text-mode screen before the PC is off).
Current kernel 5.9.8 did not fix that yet.

No such problem when I’m using the LTS kernel nor on the PC with an AMD GPU, so it seems to be related to the kernel and Nouveau’s interactions.
Comment by Bastian Beranek (totsilence) - Monday, 23 November 2020, 14:06 GMT Comment by Trit' (trit) - Wednesday, 02 December 2020, 23:53 GMT
@totsilence It could be that, indeed.
Comment by Trit' (trit) - Monday, 18 January 2021, 23:55 GMT Comment by loqs (loqs) - Tuesday, 19 January 2021, 00:20 GMT
Comment by Lime (LimeInkling) - Tuesday, 19 January 2021, 11:15 GMT
Whatever they patched must have worked, since I can no longer see any issues on the current kernel with either the nouveau or the proprietary driver. Will be requesting closure since this bug specifically mentions the NVC0.
Comment by Bastian Beranek (totsilence) - Tuesday, 19 January 2021, 11:17 GMT
The patched referenced by loqs is not yet in the kernel (I am the author), so if your issue is fixed it was unrelated after all.
Comment by Trit' (trit) - Monday, 01 February 2021, 18:08 GMT
From Bastian:

“For those wondering: It seems the patch has now been integrated mainline (it is part of 5.11-rc6) and should land in Linux 5.11. Thanks @karolherbst and @skeggsb! Hope that it qualifies for the stable kernel branches as well.”

It’s good to know that 5.11 will be fixed when it is released, but I hope the fix will be added to 5.10 when this branch becomes the new “linux-lts” package version (and not only for Arch Linux users), too.
Comment by Bastian Beranek (totsilence) - Monday, 01 February 2021, 21:20 GMT
They have already added it to the 5.10.x queue, so it should come out there as well.