Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#68397 - [cozy-desktop] Cozy does not launch due to an issue with the bin

Attached to Project: Community Packages
Opened by STPR (stpr) - Friday, 23 October 2020, 21:07 GMT
Last edited by Bruno Pagani (ArchangeGabriel) - Saturday, 24 October 2020, 05:01 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Bruno Pagani (ArchangeGabriel)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:


The launch scrip in /usr/bin/cozy-desktop launches app using electron5 instead of electron9, and due to that, it does not launch correctly.

Additional info:
* cozy-desktop 3.23.0-1

Steps to reproduce:
* Install cozy-desktop (pacman -S cozy-desktop).
* Launch using desktop file.
* App does not launch.
* Launch using terminal: "electron5 not found"

Possible fix:
* Replace "electron5 /usr/lib/cozy-desktop/app.asar "$@"" with "electron9 /usr/lib/cozy-desktop/app.asar "$@"". Now the app appears to launch normally.
This task depends upon

Closed by  Bruno Pagani (ArchangeGabriel)
Saturday, 24 October 2020, 05:01 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in 3.23.0-2, sorry for the oversight.

Loading...