Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#68384 - [hplip] 3.20.9-1 "Failed to open device" during scan

Attached to Project: Arch Linux
Opened by Paul (tones111) - Thursday, 22 October 2020, 18:47 GMT
Last edited by Jan de Groot (JGC) - Wednesday, 11 November 2020, 15:15 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
When using hplip version 3.20.9-1 I'm encountering errors when trying to use my multi-function printer (HP LaserJet Pro MFP M148fdw). Some of the symptoms include...
* An "Authentication is required to manage system services or other units" dialog pops up when launching gimp, xsane, hp-scan, etc.
* journalctl shows "protocol/discovery/avahiDiscovery.c 420: Failed to create client object: Daemon not running"
* The printer is listed even if the authorization dialog is cancled, but there are I/O errors when attempting to scan
* manually starting avahi service prevents the dialog from presenting, but there are still I/O errors when attempting to scan
* Attempting to scan results in a "Failed to open device 'hpaio:/net/HP_LaserJet_Pro_M148f-M149f?ip=192.168.0.119': Error during device I/O." dialog.
* I am still able to print a test page with 3.20.9-1

It would be nice if there was a way to disable the avahi scan.
Functionality is restored by rolling back to 3.20.6-3.

Maybe this is related to removing hplip-revert-plugins.patch?
This task depends upon

Closed by  Jan de Groot (JGC)
Wednesday, 11 November 2020, 15:15 GMT
Reason for closing:  Not a bug
Additional comments about closing:  version mismatch with AUR package
Comment by Paul (tones111) - Friday, 23 October 2020, 03:44 GMT
After running xsane with debug builds of the sane and hplip packages it looks like the failure during open is due to a mismatch between hplip_version (3.20.9) and plugin_version (3.20.6). Now that the AUR package has been updated to 3.20.9 the scanning functionality is working again.

It would still be nice to not have to cancel out of the annoying popup to start avahi, but that's an upstream problem. It looks like xsane always asks to probe for remote devices. Recommend closing this ticket.

Loading...