Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#68370 - [dracut] update-grub can't find initramfs images generated by dracut-install

Attached to Project: Arch Linux
Opened by TankMissile (TankMissile) - Thursday, 22 October 2020, 02:25 GMT
Last edited by Eli Schwartz (eschwartz) - Thursday, 22 October 2020, 02:32 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

/usr/share/libalpm/scripts/dracut-install generates two initramfs images: initramfs-linux-dracut.img and initramfs-linux-dracut-fallback.img. update-grub can't find them because of the way /etc/grub.d/10_linux searches for initramfs images. As a result, a /boot/grub/grub.cfg file is generated without an initrd for the menu entries. This means the system will not boot. Editing 10_linux is out of the question since it's provided upstream by the GRUB developers. The solution that would require the least amount of changes would be to edit dracut-install to generate images that update-grub can find. dracut-remove would also need to be edited.

Additional info:
* package version(s): dracut 050-1

Steps to reproduce:

Install dracut and it will automatically generate the initramfs images. From there, run update-grub to create a /boot/grub/grub.cfg file. Restart your system and attempt to boot from one of the menu entries. Your system will fail to boot since the menu entry was not supplied with an initrd.
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Thursday, 22 October 2020, 02:32 GMT
Reason for closing:  Not a bug
Additional comments about closing:  None of this comes from an official arch package
Comment by Eli Schwartz (eschwartz) - Thursday, 22 October 2020, 02:30 GMT
There is no such thing as "update-grub", where did you get this command from? Ubuntu?

/usr/share/libalpm/scripts/dracut-install is not provided by the archlinux dracut package.

Loading...