Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#68324 - Upgrading alsa-ucm-conf from 1.2.3-2 to 1.2.4-1 breaks pulseaudio with Realtek ALC3204

Attached to Project: Arch Linux
Opened by Daniel Parks (danielrparks) - Sunday, 18 October 2020, 16:25 GMT
Last edited by Doug Newgard (Scimmia) - Thursday, 22 October 2020, 03:15 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
After upgrading alsa-ucm-conf from 1.2.3-2 to 1.2.4-1, pulseaudio is no longer able to initialize my sound card (ALC3204). It falls back to Dummy Output instead. It generates the following error:

Failed to find a working profile.
Failed to load module "module-alsa-card" (argument: "device_id="1" name="pci-0000_03_00.6" card_name="alsa_card.pci-0000_03_00.6" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes avoid_resampling=no card_properties="module-udev-detect.discovered=1""): initialization failed.

Additional info:
All pulseaudio and alsa system configuration files are package defaults.
The output of pacmd list-sinks with alsa-ucm-conf rolled back is attached, as well as the journal containing the error.
This system is a Dell Inspiron 7405 2-in-1 with a Ryzen 7 4700U and onboard graphics.

Steps to reproduce:
Obtain an up-to-date Arch Linux system with an ALC3204 sound card. Onboard audio should not work.
Rollback alsa-ucm-conf to 1.2.3-2. Audio should now work.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Thursday, 22 October 2020, 03:15 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#68313 
Comment by Daniel Parks (danielrparks) - Sunday, 18 October 2020, 17:01 GMT Comment by Daniel Parks (danielrparks) - Monday, 19 October 2020, 12:58 GMT Comment by Daniel Parks (danielrparks) - Monday, 19 October 2020, 19:05 GMT
Fixed in alsa-lib 1.2.4-2.
Comment by david cheung (scruffidog) - Tuesday, 20 October 2020, 02:46 GMT
I have a ALC245 on a HP Envy x360 with 4700u which also is experiencing sound output issues after the upgrade except I'm using pipewire. The symptom seems to be that any application with audio cannot get the right sink. I would need to use the pavucontrol applet to select the manually select the proper device.

I've also noticed that alsa-lib-1.2.4-2 is again flagged as out of date so there's hope that a proper fix is coming?
Comment by david cheung (scruffidog) - Thursday, 22 October 2020, 01:38 GMT
This seems to be deteriorating, as even choosing the right sink outputs now has no sound even though pavucontrol seem to think there is a signal going to the choosen subsystem. Going to see if I can roll back to a known good state. I hope this does not completely messed up the audio subsystem....

Loading...