Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#68311 - [gimp] screenshot fails under KDE Plasma 5.20

Attached to Project: Arch Linux
Opened by Jonathan Liu (net147) - Sunday, 18 October 2020, 02:08 GMT
Last edited by Christian Hesse (eworm) - Monday, 21 March 2022, 08:19 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Christian Hesse (eworm)
Levente Polyak (anthraxx)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
Taking screenshot using GIMP running in KDE Plasma 5.20 desktop environment fails.

Additional info:
* gimp 2.10.22-1
* plasma-desktop 5.20.0-1
* https://gitlab.gnome.org/GNOME/gimp/-/issues/5785

Steps to reproduce:
1. Click File > Create > Screenshot
2. Click Snap button

Fix:
cat > /usr/share/applications/gimp-screenshot-plugin.desktop << EOF
[Desktop Entry]
Type=Application
Name=GIMP Screenshot Plugin
Exec=/usr/lib/gimp/2.0/plug-ins/screenshot/screenshot
NoDisplay=true
X-KDE-DBUS-Restricted-Interfaces=org.kde.kwin.Screenshot
EOF
This task depends upon

Closed by  Christian Hesse (eworm)
Monday, 21 March 2022, 08:19 GMT
Reason for closing:  Works for me
Additional comments about closing:  Fixed upstream
Comment by mattia (nTia89) - Sunday, 20 March 2022, 09:23 GMT
Upstream bug has been closed. Is this an issue for you?
Comment by Jonathan Liu (net147) - Sunday, 20 March 2022, 23:34 GMT
Issue does not appear in gimp 2.10.30-1.

Loading...