Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#68270 - [powerdevil] Remove networkmanager-qt and bluez-qt

Attached to Project: Arch Linux
Opened by Oskar Roesler (bionade24) - Thursday, 15 October 2020, 17:37 GMT
Last edited by Antonio Rojas (arojas) - Thursday, 15 October 2020, 17:48 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

Set cmake flags:
```
-DKF5NetworkManagerQt_FOUND=OFF \
-DKF5BluezQt_FOUND=OFF \
```

To remove unnecessary deps. Works fine for more than a year on powerdevil-light from AUR. No other distro packages those unnecessary dependencies making usage of other network clients more difficult.
This task depends upon

Closed by  Antonio Rojas (arojas)
Thursday, 15 October 2020, 17:48 GMT
Reason for closing:  Not a bug
Comment by Antonio Rojas (arojas) - Thursday, 15 October 2020, 17:48 GMT
"To remove unnecessary deps"
That *you* don't use then doesn't mean nobody else does.

"No other distro packages those unnecessary dependencies"
False
https://src.fedoraproject.org/rpms/powerdevil/blob/master/f/powerdevil.spec#_46
https://salsa.debian.org/qt-kde-team/kde/powerdevil/-/blob/master/debian/control#L21
https://gitweb.gentoo.org/repo/gentoo.git/tree/kde-plasma/powerdevil/powerdevil-5.20.0.ebuild#n52

"making usage of other network clients more difficult"
Noboby is forcing you to enable NM or preventing you from using other clients

Loading...