Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#68238 - [freetype2] Bad anti-aliasing in Firefox and Thunderbid

Attached to Project: Arch Linux
Opened by Yannick (Spike29) - Tuesday, 13 October 2020, 15:58 GMT
Last edited by Andreas Radke (AndyRTR) - Tuesday, 13 October 2020, 19:18 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Jan Alexander Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

After updating to freetype2 2.10.3, font anti-aliasing in Firefox and Thunderbird (in the UI and web content) look bad.
In Plasma settings, font anti-aliasing is enabled, and it works for Qt and other GTK applications.

Downgrading to freetype2 2.10.2 fixes the issue.

Additional info:
* freetype2 2.10.3

Unfortunately the issue is not very obvious in the screenshots attached.
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Tuesday, 13 October 2020, 19:18 GMT
Reason for closing:  Not a bug
Comment by Andreas Radke (AndyRTR) - Tuesday, 13 October 2020, 17:49 GMT
Looks like a local setup issue. Here nothing has changed. Please check you local setup: https://wiki.archlinux.org/index.php/Font_configuration#Fontconfig_configuration (see the notes there!).
Comment by James Hogan (Cide) - Tuesday, 13 October 2020, 18:07 GMT
I'm having same issue affecting Firefox font rendering after upgrading freetype2 to 2.10.3 today. Running Xfce. Reverting to 2.10.2 fixes it for me as well.
Comment by Yannick (Spike29) - Tuesday, 13 October 2020, 18:18 GMT
I checked my local setup but everything seems fine. I cleared my fontconfig configuration and cache files, with no success (same issue after logging in again).
I run Plasma, but I checked on Gnome and fonts in Firefox are displayed just fine there.
Comment by Bario (barmadrid) - Tuesday, 13 October 2020, 19:02 GMT
2.10.3 now enables subpixel rendering. Consider enabling RGB sub-pixel and LCD filter presets. (refer to wiki for more details).
Comment by Yannick (Spike29) - Tuesday, 13 October 2020, 19:17 GMT
Thanks, I did as described here: https://wiki.archlinux.org/index.php/Font_configuration#LCD_filter

Fonts in Firefox and Thunderbird are now displayed correctly :)
Too bad the LCD filter is not configurable in Plasma settings.

Loading...