Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#68228 - [bpftrace] Add libbpf as required dependency

Attached to Project: Community Packages
Opened by Daniel Xu (dxu) - Monday, 12 October 2020, 19:27 GMT
Last edited by Anatol Pomozov (anatolik) - Tuesday, 13 October 2020, 16:29 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Anatol Pomozov (anatolik)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hi, thanks for adding bpftrace to the community repo.

> Description:

It looks like bpftrace is built without libbpf (see bpftrace --info
output below).

Without libbpf, bpftrace is unable to take advantage of BTF in the
kernel. BTF is really powerful b/c bpftrace can automatically extract
struct definitions from the kernel instead of the user having to
install kernel development headers and #include header files. It
also enables the faster and more efficient kfunc/kretfunc probes.

BTF was added to the arch kernel in https://bugs.archlinux.org/task/66260 .

>
> Additional info:
> * package version(s)

$ pacman -Qi bpftrace
Name : bpftrace
Version : 0.11.0-2
Description : High-level tracing language for Linux eBPF
Architecture : x86_64
URL : https://github.com/iovisor/bpftrace
Licenses : Apache
Groups : None
Provides : None
Depends On : libelf zlib llvm-libs clang bcc
Optional Deps : libbpf: BTF support - required at compile time [installed]
Required By : None
Optional For : None
Conflicts With : None
Replaces : None
Installed Size : 3.74 MiB
Packager : Anatol Pomozov <anatol.pomozov@gmail.com>
Build Date : Sun 11 Oct 2020 08:39:17 PM PDT
Install Date : Mon 12 Oct 2020 12:17:43 PM PDT
Install Reason : Explicitly installed
Install Script : No
Validated By : Signatur

> * config and/or log files etc.

$ sudo bpftrace --info
System
OS: Linux 5.8.14-arch1-1 #1 SMP PREEMPT Wed, 07 Oct 2020 23:59:46 +0000
Arch: x86_64
[...]
libbpf: no
libbpf btf dump: no
libbpf btf dump type decl: no
[...]

> * link to upstream bug report, if any

> Steps to reproduce:

$ sudo bpftrace --info 2>&1 | grep btf:
btf: no
This task depends upon

Closed by  Anatol Pomozov (anatolik)
Tuesday, 13 October 2020, 16:29 GMT
Reason for closing:  Fixed
Additional comments about closing:  bpftrace-0.11.0-3
Comment by Anatol Pomozov (anatolik) - Monday, 12 October 2020, 21:36 GMT
oops, my bad. libbpf is enabled in bpftrace-0.11.0-3 that just landed [community]. Please take a look and let me know if you see other issues.
Comment by Daniel Xu (dxu) - Tuesday, 13 October 2020, 00:23 GMT
Awesome, thanks! Looks like it's working now.

Loading...