Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#68206 - [tomcat8] [tomcat9] Failed to start on Java 8

Attached to Project: Arch Linux
Opened by Olli (coderkun) - Sunday, 11 October 2020, 16:52 GMT
Last edited by freswa (frederik) - Sunday, 11 October 2020, 17:39 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Tomcat 8 and Tomcat 9 are both supposed to run on Java 8: https://tomcat.apache.org/whichversion.html
But with the two most recent version it throws the following exception on startup:

Okt 11, 2020 6:44:44 PM org.apache.tomcat.util.net.NioEndpoint setSocketOptions
SCHWERWIEGEND: Error setting socket options
java.lang.NoSuchMethodError: java.nio.ByteBuffer.clear()Ljava/nio/ByteBuffer;
at org.apache.tomcat.util.net.SocketBufferHandler.reset(Unknown Source)
at org.apache.tomcat.util.net.NioChannel.reset(Unknown Source)
at org.apache.tomcat.util.net.NioEndpoint.setSocketOptions(Unknown Source)
at org.apache.tomcat.util.net.NioEndpoint.setSocketOptions(Unknown Source)
at org.apache.tomcat.util.net.Acceptor.run(Unknown Source)
at java.lang.Thread.run(Thread.java:748)

Versions 8.5.57 and 9.0.37 both work fine. Looking at the changelog for the package it looks like the PKGBUILDs switched from the pre-build files to compiling it themselves: https://github.com/archlinux/svntogit-packages/commit/38d4200e82741542801561ea7c2805fb11410876#diff-8d0411b338c83cd8cd8ad9d9db127101

Has maybe the wrong Java version be used for compilation? Or is a compatibiliy flag missing?

Additional info:
* package version(s): 8.5.58, 8.5.59, 9.0.38, 9.0.39

Steps to reproduce:
* Update tomcat8 or tomcat9 to the latest version
* Either configure “java-8-openjdk” as the default Java version using `archlinux-java` or start Tomcat manually specifying `/usr/lib/jvm/java-8-openjdk/` as `JAVA_HOME`
* Start Tomcat
This task depends upon

Closed by  freswa (frederik)
Sunday, 11 October 2020, 17:39 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#68154 

Loading...