Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#68190 - [nginx] Enable IPv6 in PKGBUILD

Attached to Project: Arch Linux
Opened by Ryan Long (nitronarcosis) - Saturday, 10 October 2020, 21:57 GMT
Last edited by Bartłomiej Piotrowski (Barthalion) - Wednesday, 14 October 2020, 07:59 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Bartłomiej Piotrowski (Barthalion)
Giancarlo Razzolini (grazzolini)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: I would like to add a flag to the nginx PKGBUILD so that nginx is compiled with IPv6 support. It looks like this had previously been enabled and was lost when the compilation flags were rearranged.
I've attached a proposed PKGBUILD with the --with-ipv6 flag included and pkgrel incremented.

Additional info:
* package version(s) 1.12.0+

Steps to reproduce:
N/A
This task depends upon

Closed by  Bartłomiej Piotrowski (Barthalion)
Wednesday, 14 October 2020, 07:59 GMT
Reason for closing:  Not a bug
Comment by Bartłomiej Piotrowski (Barthalion) - Tuesday, 13 October 2020, 17:46 GMT
Is there an actual bug or you just want it for cosmetic reasons?
Comment by Ryan Long (nitronarcosis) - Tuesday, 13 October 2020, 19:55 GMT
My understanding is that IPv6 can provide performance benefits, especially when dealing with IPv6 only mobile networks. I understand that this is neither a bug nor a feature, but this is the best venue I could find to address changes to packaging.
Comment by Bartłomiej Piotrowski (Barthalion) - Tuesday, 13 October 2020, 20:42 GMT
IPv6 is enabled automatically during build if the system supports it. I assure you Arch does.
Comment by Ryan Long (nitronarcosis) - Wednesday, 14 October 2020, 06:57 GMT
Apologies, the IPv6 issues I was having were due to a series of interesting configuration decisions

Loading...