Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#68183 - [freecad] libmedC.so.11.0.0: cannot open shared object file: No such file or directory

Attached to Project: Community Packages
Opened by Tomas Mudrunka (harvie) - Saturday, 10 October 2020, 17:41 GMT
Last edited by Alexander F. Rødseth (xyproto) - Sunday, 11 October 2020, 20:36 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Alexander F. Rødseth (xyproto)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
Hello,
glad to hear that there is finaly a pre-built package for freecad! thank you.
I also feel obligued to report this bug, which happens when i try to open Path workbench:


libmedC.so.11.0.0: cannot open shared object file: No such file or directory
Traceback (most recent call last):
File "<string>", line 75, in Initialize
File "/usr/lib/freecad/Mod/Path/PathScripts/PathGuiInit.py", line 69, in Startup
from PathScripts import PathSurfaceGui
File "/usr/lib/python3.8/site-packages/shiboken2/files.dir/shibokensupport/__feature__.py", line 146, in _import
return original_import(name, *args, **kwargs)
File "/usr/lib/freecad/Mod/Path/PathScripts/PathSurfaceGui.py", line 27, in <module>
import PathScripts.PathSurface as PathSurface
File "/usr/lib/python3.8/site-packages/shiboken2/files.dir/shibokensupport/__feature__.py", line 146, in _import
return original_import(name, *args, **kwargs)
File "/usr/lib/freecad/Mod/Path/PathScripts/PathSurface.py", line 28, in <module>
import MeshPart
File "/usr/lib/python3.8/site-packages/shiboken2/files.dir/shibokensupport/__feature__.py", line 146, in _import
return original_import(name, *args, **kwargs)


Additional info:
* package version(s) freecad-0.18.4-3
* config and/or log files etc.
* link to upstream bug report, if any

Steps to reproduce:

launch freecad, switch to path workbench
This task depends upon

Closed by  Alexander F. Rødseth (xyproto)
Sunday, 11 October 2020, 20:36 GMT
Reason for closing:  Not a bug
Comment by Alexander F. Rødseth (xyproto) - Sunday, 11 October 2020, 11:13 GMT
Thanks for reporting!

1. Have you installed the official "med" package? It provides /usr/lib/libmedC.so.11.0.0.
2. Have you removed all FreeCAD-related dependencies from AUR, and then updated all pacakges and then tried installing FreeCAD? (`pacman -Syu` then `pacman -S freecad`)?
Comment by Tomas Mudrunka (harvie) - Sunday, 11 October 2020, 15:34 GMT
> 1. Have you installed the official "med" package? It provides /usr/lib/libmedC.so.11.0.0.

Oh. i had med3 package installed from aur... Perhaps you should specify freecad dependency as med>=4 rather than just plain med.
Comment by Alexander F. Rødseth (xyproto) - Sunday, 11 October 2020, 20:36 GMT
Thanks for the response. AUR is unsupported and not considered a part of "official Arch Linux".

Loading...