Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#68117 - [openssh] ssh-copy-id script is broken

Attached to Project: Arch Linux
Opened by Ronan Pigott (Brocellous) - Tuesday, 06 October 2020, 02:20 GMT
Last edited by Giancarlo Razzolini (grazzolini) - Monday, 26 October 2020, 10:36 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Lukas Fleischer (lfleischer)
Levente Polyak (anthraxx)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 9
Private No

Details

Description:
ssh-copy-id is broken due to a syntax error which is fixed upstream [1].

additional info:
openssh 8.4p1-1

[1] https://github.com/openssh/openssh-portable/commit/d9e727dcc04a52caaac87543ea1d230e9e6b5604
This task depends upon

Closed by  Giancarlo Razzolini (grazzolini)
Monday, 26 October 2020, 10:36 GMT
Reason for closing:  Fixed
Additional comments about closing:  openssh-8.4p1-2 implements the patched ssh-copy-id.
Comment by aiyion (aiyion) - Tuesday, 06 October 2020, 14:38 GMT
Just reproduced the error at the cost of several ubuntu installations.
Manually applying the upstream fix solves the problem;
I have not enabled testing repos.
Comment by Markus Enax (mnx) - Thursday, 08 October 2020, 07:23 GMT
Side note: The error is causing the public key to be added to the local .ssh/authorized_keys file instead.
Comment by Cpt Pcrd (cptpcrd) - Wednesday, 21 October 2020, 18:11 GMT
Is it possible to get a fix for this? The whole point of ssh-copy-id is to avoid having to copy the key manually, so the fact that it's now completely broken is starting to get annoying.

Loading...