Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#68109 - privoxy install fails due to conflicting files

Attached to Project: Community Packages
Opened by Greg (skimj) - Monday, 05 October 2020, 02:59 GMT
Last edited by Doug Newgard (Scimmia) - Monday, 05 October 2020, 15:11 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To freswa (frederik)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I migrated /etc/privoxy files to new installation but pacman install failed due to 'conflicting files'
```
error: failed to commit transaction (conflicting files)
privoxy: /etc/privoxy/regression-tests.action exists in filesystem
privoxy: /etc/privoxy/templates/blocked exists in filesystem
privoxy: /etc/privoxy/templates/cgi-error-404 exists in filesystem
<snip lots of /etc/privoxy/templates/ files>
```
Privoxy version 3.0.28-2

I didn't care about the existing files so I deleted them and then the install succeeded. I would suggest adding regression-tests.action and templates/* to the backup array in PKGBUILD
This task depends upon

Closed by  Doug Newgard (Scimmia)
Monday, 05 October 2020, 15:11 GMT
Reason for closing:  Not a bug
Comment by Doug Newgard (Scimmia) - Monday, 05 October 2020, 03:08 GMT
Where did all of those files come from before?
Comment by Doug Newgard (Scimmia) - Monday, 05 October 2020, 15:11 GMT
3.0.28-1 already had those files, so this is probably just database/filesystem corruption. See the wiki.

Loading...