Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#68083 - Kernel crashes during boot on Virtualbox

Attached to Project: Arch Linux
Opened by Angus McInnes (jib) - Saturday, 03 October 2020, 06:07 GMT
Last edited by freswa (frederik) - Monday, 05 October 2020, 12:17 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To No-one
Architecture x86_64
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Steps to reproduce:
- Using Virtualbox 6.1.14r140239 on Windows 10 host
- Create a new virtual machine; give it a name, set type/version to Arch Linux (64-bit), leave everything else at the defaults, and click create
- Start the new virtual machine. When it asks for a start-up disk, select archlinux-2020.10.01-x86_64.iso
- Wait for it to boot. If the bug occurs (it reliably does for me) the virtual machine will crash with either a blank screen or a kernel stacktrace

Other observations:
- Screen recording from the VM is attached, showing the kernel crash
- If you put module_blacklist=intel_rapl_msr on the kernel command line, it does not crash, and successfully boots to the login prompt
This task depends upon

Closed by  freswa (frederik)
Monday, 05 October 2020, 12:17 GMT
Reason for closing:  Not a bug
Comment by Angus McInnes (jib) - Saturday, 03 October 2020, 06:28 GMT
On further investigation, my virtual machine seems to be breaking in other random ways (like memory is being corrupted) so if no one can reproduce this I think we should blame my host and/or VirtualBox rather than a kernel bug.

Loading...