Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#68030 - [broadcom-wl-dkms] Doesn't compile with kernel >= 5.9

Attached to Project: Community Packages
Opened by Rolf Evers-Fischer (embedded24) - Monday, 28 September 2020, 14:34 GMT
Last edited by Doug Newgard (Scimmia) - Monday, 28 September 2020, 14:46 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

In kernel versions before 5.9 there was a macro called "segment_eq". This macro was only used to implement "uaccess_kernel" (also here!) and removed with 5.9.0. Now broadcom-wl-dkms fails to build as it can't find it.


Additional info:
* package version(s): 6.30.223.271-22
* Excerpt from the /var/lib/dkms/broadcom-wl/6.30.223.271/build/make.log:
/var/lib/dkms/broadcom-wl/6.30.223.271/build/src/wl/sys/wl_linux.c: In function ‘wl_ioctl’:
/var/lib/dkms/broadcom-wl/6.30.223.271/build/src/wl/sys/wl_linux.c:1650:6: error: implicit declaration of function ‘segment_eq’ [-Werror=implicit-function-declaration]
1650 | if (segment_eq(get_fs(), KERNEL_DS))
| ^~~~~~~~~~

Steps to reproduce:
* Install linux-mainline kernel
* Try to compile broadcom-wl-dkms

The attached patch fixes the problem. It has been tested on a Dell E5410.

This task depends upon

Closed by  Doug Newgard (Scimmia)
Monday, 28 September 2020, 14:46 GMT
Reason for closing:  Not a bug
Additional comments about closing:  AUR packages are not supported (linux-mainline)

Loading...