Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#68027 - [k3b] Unable to use change permissions button in 1:20.08.1-1

Attached to Project: Arch Linux
Opened by Nathaniel Chin (nathanielcwm) - Monday, 28 September 2020, 12:48 GMT
Last edited by Antonio Rojas (arojas) - Tuesday, 29 September 2020, 05:54 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Antonio Rojas (arojas)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Going to Settings > Programs > Permissions and clicking Change Permissions makes it pop up with an error.

Error in question:
Unable to execute the action: DBus Backend error: service start org.kde.k3b failed: Cannot launch daemon, file not found or permissions invalid.

It looks like it is looking for /usr/lib/kauth/k3bhelper however it is instead located in /usr/lib/k3bhelper

Additional info:
* package version(s): 1:20.08.1-1

Steps to reproduce:
Open k3b.
Open settings menu.
Click on programs.
Click on permissions.
Click change permissions.
Observe error message.
This task depends upon

Closed by  Antonio Rojas (arojas)
Tuesday, 29 September 2020, 05:54 GMT
Reason for closing:  Fixed
Additional comments about closing:  k3b 20.08.1-2
Comment by Nathaniel Chin (nathanielcwm) - Monday, 28 September 2020, 12:49 GMT
Changing /usr/share/dbus-1/system-services/org.kde.k3b.service to point towards /usr/lib/k3bhelper instead fixes the issue.

Loading...