Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#68 - System configuration rc.conf and conf.d

Attached to Project: Arch Linux
Opened by Andreas Schweitzer - known as andy elsewhere in AL (aschweitzer) - Saturday, 31 May 2003, 15:57 GMT
Last edited by Judd Vinet (judd) - Thursday, 05 June 2003, 04:51 GMT
Task Type Bug Report
Category System
Status Closed
Assigned To Judd Vinet (judd)
Architecture All
Severity Very Low
Priority Normal
Reported Version 0.6 Widget
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

I personally love to have as much configuration as possible in /etc/rc.conf and don't like to have a myriad of files sitting around. I hope that /etc/conf.d is not starting that :-)

Anyways, my suggestion would be, to first parse /etc/conf.d/* right at the beginning of /etc/rc.conf - somehow as defaults - and then let the admin (who wishes so) change things in /etc/rc.conf
This task depends upon

Closed by  Anonymous Submitter

Reason for closing:  Not a bug
Comment by Judd Vinet (judd) - Thursday, 05 June 2003, 04:51 GMT
  • Task details edited
Sounds fine to me. conf.d parsing has been moved to the top of rc.conf in initscripts 0.5-3.

Loading...