Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#67950 - [ffms2] symbol lookup error with aegisub

Attached to Project: Community Packages
Opened by Marcel Korpel (Marcel-) - Sunday, 20 September 2020, 23:31 GMT
Last edited by freswa (frederik) - Sunday, 11 October 2020, 23:23 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Maxime Gauduin (Alucryd)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

When starting Aegisub 3.2.2-40 when ffms2 2.40-1 is installed, the program exits with message

"aegisub-3.2: symbol lookup error: aegisub-3.2: undefined symbol: FFMS_DoIndexing"

Everything works fine (at least a functional program) with ffms2 2.23.1-4.
This task depends upon

Closed by  freswa (frederik)
Sunday, 11 October 2020, 23:23 GMT
Reason for closing:  Fixed
Additional comments about closing:  aegisub 3.2.2-41
Comment by loqs (loqs) - Tuesday, 22 September 2020, 01:51 GMT
Upstream is changing the API/ABI [1] with no soname bump [2].

[1] https://github.com/FFMS/ffms2/commit/1a234497d46816ebc2b79afdf64914b6c11be502
[2] https://github.com/FFMS/ffms2/issues/359#issuecomment-683291246
Edit:
aegisub is not compatible with the new version without patching. Seems to need more than just [3].

[3] https://github.com/Aegisub/Aegisub/commit/1aa9215e7fc360de05da9b7ec2cd68f1940af8b2

Also needed 7a6da26be6a830f4e1255091952cc0a1326a4520 and ebc76c8a1168d16054a1f7c6d3920c0fa9c9d717 (which does not apply cleanly edited version attached) plus changing -Wno-c++11-narrowing to -Wno-narrowing.
With those changes the package builds.
Comment by Marcel Korpel (Marcel-) - Sunday, 11 October 2020, 23:09 GMT
Thanks for patching aegisub; although I don't understand everything that the patches do (though I agree X11 is wonderful), aegisub seems to work again. Only one warning shows up:

Warning: Mismatch between the program and library build versions detected.
The library used 3.0 (wchar_t,compiler with C++ ABI 1013,wx containers,compatible with 2.8),
and your program used 3.0 (wchar_t,compiler with C++ ABI 1014,wx containers,compatible with 2.8).

Loading...