Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#67938 - [GIMP] Bug Report

Attached to Project: Arch Linux
Opened by Shreyans Jain (DestroyerX) - Saturday, 19 September 2020, 13:02 GMT
Last edited by Christian Hesse (eworm) - Monday, 21 March 2022, 08:18 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Christian Hesse (eworm)
Levente Polyak (anthraxx)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

```
GNU Image Manipulation Program version 2.10.20
git-describe: GIMP_2_10_18-332-g68d21512bf
Build: unknown rev 0 for linux
# C compiler #
Using built-in specs.
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/usr/lib/gcc/x86_64-pc-linux-gnu/10.1.0/lto-wrapper
Target: x86_64-pc-linux-gnu
Configured with: /build/gcc/src/gcc/configure --prefix=/usr --libdir=/usr/lib --libexecdir=/usr/lib --mandir=/usr/share/man --infodir=/usr/share/info --with-bugurl=https://bugs.archlinux.org/ --enable-languages=c,c++,ada,fortran,go,lto,objc,obj-c++,d --with-isl --with-linker-hash-style=gnu --with-system-zlib --enable-__cxa_atexit --enable-cet=auto --enable-checking=release --enable-clocale=gnu --enable-default-pie --enable-default-ssp --enable-gnu-indirect-function --enable-gnu-unique-object --enable-install-libiberty --enable-linker-build-id --enable-lto --enable-multilib --enable-plugin --enable-shared --enable-threads=posix --disable-libssp --disable-libstdcxx-pch --disable-libunwind-exceptions --disable-werror gdc_include_dir=/usr/include/dlang/gdc
Thread model: posix
Supported LTO compression algorithms: zlib zstd
gcc version 10.1.0 (GCC)

# Libraries #
using babl version 0.1.78 (compiled against version 0.1.78)
using GEGL version 0.4.24 (compiled against version 0.4.24)
using GLib version 2.66.0 (compiled against version 2.64.3)
using GdkPixbuf version 2.40.1 (compiled against version 2.40.0)
using GTK+ version 2.24.32 (compiled against version 2.24.32)
using Pango version 1.46.1 (compiled against version 1.44.7)
using Fontconfig version 2.13.91 (compiled against version 2.13.91)
using Cairo version 1.17.3 (compiled against version 1.17.3)

```
> fatal error: Segmentation fault

Stack trace:
```
/usr/lib/libgimpbase-2.0.so.0(gimp_stack_trace_print+0x3b9)[0x7ffa575b9729]
gimp-2.10(+0xd45e4)[0x561ad0cd45e4]
gimp-2.10(+0xd4a48)[0x561ad0cd4a48]
gimp-2.10(+0xd50db)[0x561ad0cd50db]
/usr/lib/libpthread.so.0(+0x140f0)[0x7ffa565a70f0]
gimp-2.10(file_open_image+0x511)[0x561ad10d34e1]
gimp-2.10(file_open_with_proc_and_display+0x23d)[0x561ad10d43cd]
gimp-2.10(file_open_from_command_line+0x1aa)[0x561ad10d4d1a]
gimp-2.10(app_run+0x31e)[0x561ad0cd3cbe]
gimp-2.10(main+0x39a)[0x561ad0cd35ca]
/usr/lib/libc.so.6(__libc_start_main+0xf2)[0x7ffa563f2152]
gimp-2.10(_start+0x2e)[0x561ad0cd375e]

```
This task depends upon

Closed by  Christian Hesse (eworm)
Monday, 21 March 2022, 08:18 GMT
Reason for closing:  Works for me
Additional comments about closing:  not reproducible
Comment by mattia (nTia89) - Sunday, 20 March 2022, 09:23 GMT
I cannot reproduce the issue. Is it still valid for you?
Comment by Shreyans Jain (DestroyerX) - Sunday, 20 March 2022, 09:27 GMT
Sorry but I stopped using GIMP

Loading...