Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#67915 - Linux 5.8 (probably all versions) reports wrong info about partitions.

Attached to Project: Arch Linux
Opened by Nicholas (Chawoosh) - Thursday, 17 September 2020, 07:01 GMT
Last edited by freswa (frederik) - Thursday, 17 September 2020, 11:34 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: Linux 5.8 (probably all versions) reports wrong info about partitions.


Additional info:
* package version(s)Linux 5.8.9-arch2-1
* config and/or log files etc. standard
*

Steps to reproduce:
partprobe /dev/sda
Error: Partition(s) 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20, 21, 22, 23, 24, 25, 26, 27, 28, 29, 30, 31, 32, 33, 34, 35, 36, 37, 38, 39, 40, 41, 42, 43, 44, 45, 46, 47, 48, 49, 50, 51, 52, 53, 54, 55, 56, 57, 58, 59, 60, 61, 62, 63, 64 on /dev/sda have been written, but we have been unable to inform the kernel of the change, probably because it/they are in use. As a result, the old partition(s) will remain in use. You should reboot now before making further changes.
This task depends upon

Closed by  freswa (frederik)
Thursday, 17 September 2020, 11:34 GMT
Reason for closing:  Duplicate
Additional comments about closing:  FS#67891 - re-opened
Comment by Jan de Groot (JGC) - Thursday, 17 September 2020, 08:06 GMT
What's the bug here? What information is wrong?
Comment by Nicholas (Chawoosh) - Thursday, 17 September 2020, 08:26 GMT
Disk has three partitions, but all programs receive this info and most of this (working with disks) report an error.
Comment by nl6720 (nl6720) - Thursday, 17 September 2020, 08:50 GMT
FS#67891 ? It should have been fixed in linux 5.8.9.arch2-1.

Loading...