Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#67821 - System freeze/kernel panic when Firefox is opened or closed while Virtualbox VMs are running

Attached to Project: Arch Linux
Opened by abcdefg (horsearcher) - Thursday, 03 September 2020, 19:26 GMT
Last edited by freswa (frederik) - Friday, 04 September 2020, 21:47 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To No-one
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
I had two Virtualbox virtual machines running, and when I closed Firefox (on the host system), my computer froze completely. Even forced reboot via Alt+SysRq+B didn't work (these keys are enabled and work normally).
I tried again, booted the same VMs and started Firefox, system froze immediately. I managed to repeat this multiple times. Sometimes Caps lock and Scroll lock lights started flashing, indicating a kernel panic, sometimes not. Switch to text mode did not occur.

Additional info:
Hardware:
Intel(R) Xeon(R) CPU E3-1230 V2 @ 3.30GHz
16 GB RAM
Nvidia GTX 980 Ti, using Nouveau driver

Firefox version: 80.0.1
Hardware acceleration is apparently disabled? (about:support reports "Compositing: Basic")

Desktop: KDE Plasma, using X11

Virtualbox version: 6.1.12 r139181
Virtualbox DKMS kernel module is used

Kernel (from uname -a): 5.8.5-arch1-1

Latest system updates were installed today.



Steps to reproduce:
* Boot two Virtualbox VMs (one may be enough)
* Start Firefox
This task depends upon

Closed by  freswa (frederik)
Friday, 04 September 2020, 21:47 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Not a packaging bug.
Comment by JD (Karadoc-V) - Friday, 04 September 2020, 07:45 GMT
This is not related to Firefox, but to VirtualBox host with kernel 5.8.x. See https://bbs.archlinux.org/viewtopic.php?id=258217
The trunk version of VirtualBox solves the problem, but is not rolled-out for now. It should be soon, as seen on https://www.virtualbox.org/ticket/19644

There are two parameters that might solve the problem (changing network mode and/or USB emulation version), but this does not work in any situation.
The only reliable solution for now is to use VirtualBox with DKMS modules on host, downgrading kernel to the LTS version, and configuring your bootloader to start on the LTS kernel.

Loading...