Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#67771 - [chromium] chromium-85 slow on wayland gnome

Attached to Project: Arch Linux
Opened by soloturn (soloturn) - Sunday, 30 August 2020, 16:22 GMT
Last edited by Evangelos Foutras (foutrelis) - Friday, 19 March 2021, 06:02 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Evangelos Foutras (foutrelis)
Felix Yan (felixonmars)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
chromium-85 is slow when opening multiple videos on youtube. there is nothing in the log files. no .config/chromium-flags.conf does exist. downgrading to chromium-84 makes it quick again. i checked the commit diff and there is one:
#[libvpx]=libvpx

can it be that this is the cause?
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Friday, 19 March 2021, 06:02 GMT
Reason for closing:  Upstream
Additional comments about closing:  Tracked and/or fixed in various upstream issues.
Comment by tinywrkb (tinywrkb) - Monday, 31 August 2020, 03:23 GMT
I also noticed this with Chrome (Flatpak sandbox) running in the Sway compositor and just wanted to point out that this might not be restricted to videos and that on my system it seems to affect responsiveness and page load time when having multiple tabs and windows.
I couldn't replicate this in a clean browser environment so it's possible that having multiple extensions is also affecting the severity of this issue.
And as far as I can tell there's nothing useful in the log even when running with --enable-logging=stderr.

Note that I confirmed that this is also happening with chromium from the Extra repo, but the Chrome (Flatpak) is my daily driver.
And I should add that the first test I made is to confirm that this is not a regression of the latest xorg 1.20.9-1 packages releases but of Chrome/Chromium 85.0.4183.83-1.
Comment by Evangelos Foutras (foutrelis) - Monday, 31 August 2020, 19:39 GMT
Tracked upstream at https://crbug.com/1121782
Comment by soloturn (soloturn) - Friday, 09 October 2020, 18:21 GMT
from upstream, parameter --use-cmd-decoder=validating makes it work again.

Loading...