Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#67754 - [qbittorrent][libtorrent-rasterbar] qbittorrent: symbol lookup error: qbittorrent: undefined symbol

Attached to Project: Community Packages
Opened by nl6720 (nl6720) - Saturday, 29 August 2020, 10:55 GMT
Last edited by freswa (frederik) - Wednesday, 23 September 2020, 14:37 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Felix Yan (felixonmars)
Eli Schwartz (eschwartz)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 7
Private No

Details

Description:
After upgrading libtorrent-rasterbar from 1:1.2.8-1 to 1:1.2.9-1, qbittorrent doesn't launch anymore.

qbittorrent: symbol lookup error: qbittorrent: undefined symbol: _ZN10libtorrent5entryC1ESt3mapINSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEES0_NS_3aux12strview_lessESaISt4pairIKS7_S0_EEE

Additional info:
* package version(s)
* config and/or log files etc.
* link to upstream bug report, if any
qbittorrent 4.2.5-1
libtorrent-rasterbar 1:1.2.9-1


Steps to reproduce:
Try to run qbittorrent
This task depends upon

Closed by  freswa (frederik)
Wednesday, 23 September 2020, 14:37 GMT
Reason for closing:  Fixed
Additional comments about closing:  1:1.2.10-2
Comment by Eli Schwartz (eschwartz) - Sunday, 30 August 2020, 19:57 GMT
See https://github.com/arvidn/libtorrent/issues/5024

libtorrent-rasterbar needs to be built with the C++14 std, because qbittorrent is.

This then breaks the python bindings which fail to build due to internally overriding the std and setting it back to C++11.

Pending fix being discussed in https://github.com/arvidn/libtorrent/pull/5026
Comment by Eli Schwartz (eschwartz) - Wednesday, 23 September 2020, 12:07 GMT
Why was the package moved from testing to extra without being fixed?
Comment by Felix Yan (felixonmars) - Wednesday, 23 September 2020, 12:44 GMT
Sorry, I had broken memories that 1.2.10 fixed this already. I have applied the patch in https://github.com/arvidn/libtorrent/pull/5026 and released libtorrent-rasterbar 1:1.2.10-2 to [extra] as a hotfix for now.
Comment by John Barks (Zod) - Wednesday, 23 September 2020, 14:06 GMT
The new version of libtorrent-rasterbar fixes qbittorrent for me but the 'downloaded from mirror' file is named "libtorrent-rasterbar-1 1.2.10-2-x86_64.pkg.tar.zst" I had to rename it to fill in the blank in order to install.
Comment by Eli Schwartz (eschwartz) - Wednesday, 23 September 2020, 14:11 GMT
The blank is actually a ":" character and it's correct on the server afaict. pacman -Syu should download it just fine. What did you use to download it?
Comment by nl6720 (nl6720) - Wednesday, 23 September 2020, 14:13 GMT
I'm guessing it was a download from https://www.archlinux.org/packages/extra/x86_64/libtorrent-rasterbar/download/ using a browser.
Firefox saves the file as "libtorrent-rasterbar-1 1.2.10-2-x86_64.pkg.tar.zst".
Comment by John Barks (Zod) - Wednesday, 23 September 2020, 14:15 GMT Comment by a (a) - Wednesday, 23 September 2020, 14:24 GMT
2 hours since commit and my `pacman` hadn't the -2 yet (-Syy change nothing)

...Anyway with a `yay -U --asdeps Downloads/libtorrent-rasterbar-1\ 1.2.10-2-x86_64.pkg.tar.zst` it's ok
Comment by Eli Schwartz (eschwartz) - Wednesday, 23 September 2020, 14:30 GMT
https://www.archlinux.org/mirrors/status/

Select a mirror with 0:00 delay, those sync once a minute. :D
Comment by Eli Schwartz (eschwartz) - Wednesday, 23 September 2020, 14:32 GMT
@Zod @nl6720 yeah, downloading that exact link with wget should do the right thing.

Loading...