Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#67713 - [mediawiki] add diffutils to depends and git to optdepends

Attached to Project: Community Packages
Opened by nl6720 (nl6720) - Tuesday, 25 August 2020, 07:09 GMT
Last edited by freswa (frederik) - Tuesday, 25 August 2020, 09:47 GMT
Task Type Feature Request
Category Packages
Status Assigned
Assigned To Sergej Pupykin (sergej)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 1
Private No

Details

Description:
During the initial MediaWiki setup, if diffutils is not installed it shows:
GNU diff3 text comparison utility not found. You can ignore this for now, but might run into edit conflicts more frequently.

git is used to show git hashes if an extension is running off of a git checkout. Without it, the initial setup shows:
Git version control software not found. You can ignore this for now. Note Special:Version will not display commit hashes.

Please add diffutils to depends and git to optdepends.
The PKGBUILD also has a commented out optdepend "php-apcu". Please uncomment it.


Additional info:
* package version(s)
* config and/or log files etc.
* link to upstream bug report, if any
mediawiki 1.34.2-2


Steps to reproduce:
Start the initial setup in a fresh installation without without LocalSettings.php.
This task depends upon

Loading...