Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#67712 - gimp crashed.

Attached to Project: Arch Linux
Opened by Matthew (MattMadness) - Tuesday, 25 August 2020, 02:39 GMT
Last edited by freswa (frederik) - Tuesday, 25 August 2020, 09:48 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

gimp crashed

Additional info:
```
GNU Image Manipulation Program version 2.10.20
git-describe: GIMP_2_10_18-332-g68d21512bf
Build: unknown rev 0 for linux
# C compiler #
Using built-in specs.
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/usr/lib/gcc/x86_64-pc-linux-gnu/10.1.0/lto-wrapper
Target: x86_64-pc-linux-gnu
Configured with: /build/gcc/src/gcc/configure --prefix=/usr --libdir=/usr/lib --libexecdir=/usr/lib --mandir=/usr/share/man --infodir=/usr/share/info --with-bugurl=https://bugs.archlinux.org/ --enable-languages=c,c++,ada,fortran,go,lto,objc,obj-c++,d --with-isl --with-linker-hash-style=gnu --with-system-zlib --enable-__cxa_atexit --enable-cet=auto --enable-checking=release --enable-clocale=gnu --enable-default-pie --enable-default-ssp --enable-gnu-indirect-function --enable-gnu-unique-object --enable-install-libiberty --enable-linker-build-id --enable-lto --enable-multilib --enable-plugin --enable-shared --enable-threads=posix --disable-libssp --disable-libstdcxx-pch --disable-libunwind-exceptions --disable-werror gdc_include_dir=/usr/include/dlang/gdc
Thread model: posix
Supported LTO compression algorithms: zlib zstd
gcc version 10.1.0 (GCC)

# Libraries #
using babl version 0.1.78 (compiled against version 0.1.78)
using GEGL version 0.4.24 (compiled against version 0.4.24)
using GLib version 2.64.5 (compiled against version 2.64.3)
using GdkPixbuf version 2.40.1 (compiled against version 2.40.0)
using GTK+ version 2.24.32 (compiled against version 2.24.32)
using Pango version 1.46.1 (compiled against version 1.44.7)
using Fontconfig version 2.13.91 (compiled against version 2.13.91)
using Cairo version 1.17.3 (compiled against version 1.17.3)

```
> fatal error: Aborted

Stack trace:
```
/usr/lib/libgimpbase-2.0.so.0(gimp_stack_trace_print+0x3b9)[0x7f0e2edea729]
gimp-2.10(+0xd45e4)[0x55fe302525e4]
gimp-2.10(+0xd4a48)[0x55fe30252a48]
gimp-2.10(+0xd50db)[0x55fe302530db]
/usr/lib/libpthread.so.0(+0x140f0)[0x7f0e2dde30f0]
/usr/lib/libc.so.6(gsignal+0x145)[0x7f0e2dc43615]
/usr/lib/libc.so.6(abort+0x116)[0x7f0e2dc2c862]
/usr/lib/libc.so.6(+0x26747)[0x7f0e2dc2c747]
/usr/lib/libc.so.6(+0x35bf6)[0x7f0e2dc3bbf6]
/usr/lib/libX11.so.6(+0x40c59)[0x7f0e2daedc59]
/usr/lib/libX11.so.6(+0x40cfe)[0x7f0e2daedcfe]
/usr/lib/libX11.so.6(_XEventsQueued+0x52)[0x7f0e2daedff2]
/usr/lib/libX11.so.6(XPending+0x62)[0x7f0e2dadf992]
/usr/lib/libgdk-x11-2.0.so.0(+0x572a9)[0x7f0e2e8ec2a9]
/usr/lib/libglib-2.0.so.0(g_main_context_check+0x1da)[0x7f0e2df88dda]
/usr/lib/libglib-2.0.so.0(+0xa010b)[0x7f0e2dfd910b]
/usr/lib/libglib-2.0.so.0(g_main_loop_run+0x83)[0x7f0e2df89c03]
gimp-2.10(app_run+0x38e)[0x55fe30251d2e]
gimp-2.10(main+0x39a)[0x55fe302515ca]
/usr/lib/libc.so.6(__libc_start_main+0xf2)[0x7f0e2dc2e152]
gimp-2.10(_start+0x2e)[0x55fe3025175e]

```

Steps to reproduce:

I don't know
This task depends upon

Closed by  freswa (frederik)
Tuesday, 25 August 2020, 09:48 GMT
Reason for closing:  Not a bug
Additional comments about closing:  "I don't know" doesn't help anyone here. Please adhere to the bug reporting guidlines or use the forum, the mailing list or the irc to ask for support. Thank you

Loading...