Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#67706 - [libreoffice-fresh] "undefined symbol: FT_Palette_Select" prevents start

Attached to Project: Arch Linux
Opened by Térence Clastres (Terence) - Monday, 24 August 2020, 19:09 GMT
Last edited by Doug Newgard (Scimmia) - Tuesday, 25 August 2020, 01:58 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:

Libreoffice doesn't start and shows the following:
`/usr/lib/libreoffice/program/soffice.bin: symbol lookup error: /usr/lib/libreoffice/program/libskialo.so: undefined symbol: FT_Palette_Select`

Using `LD_PRELOAD=/usr/lib/libfreetype.so.6 libreoffice` makes it start.



Additional info:
* package version
libreoffice-fresh 7.0.0-2,
freetype2 2.10.2-1

Output of `ldd /usr/lib/libreoffice/program/libskialo.so`:

```
linux-vdso.so.1 (0x00007ffe535eb000)
libfreetype.so.6 => /usr/lib/libreoffice/program/libfreetype.so.6 (0x00007f111e736000)
libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0x00007f111e69d000)
libpng16.so.16 => /usr/lib/libpng16.so.16 (0x00007f111e666000)
libdl.so.2 => /usr/lib/libdl.so.2 (0x00007f111e660000)
libX11-xcb.so.1 => /usr/lib/libX11-xcb.so.1 (0x00007f111e65b000)
libX11.so.6 => /usr/lib/libX11.so.6 (0x00007f111e51a000)
libuno_sal.so.3 => /usr/lib/libreoffice/program/libuno_sal.so.3 (0x00007f111e4b1000)
libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00007f111e2d4000)
libm.so.6 => /usr/lib/libm.so.6 (0x00007f111e18e000)
libgcc_s.so.1 => /usr/lib/libgcc_s.so.1 (0x00007f111e174000)
libpthread.so.0 => /usr/lib/libpthread.so.0 (0x00007f111e152000)
libc.so.6 => /usr/lib/libc.so.6 (0x00007f111df89000)
/usr/lib64/ld-linux-x86-64.so.2 (0x00007f111f0e9000)
libbz2.so.1.0 => /usr/lib/libbz2.so.1.0 (0x00007f111df74000)
libz.so.1 => /usr/lib/libz.so.1 (0x00007f111df5a000)
libharfbuzz.so.0 => /usr/lib/libharfbuzz.so.0 (0x00007f111de8b000)
libexpat.so.1 => /usr/lib/libexpat.so.1 (0x00007f111de5b000)
libxcb.so.1 => /usr/lib/libxcb.so.1 (0x00007f111de31000)
libgraphite2.so.3 => /usr/lib/libgraphite2.so.3 (0x00007f111de0a000)
libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0x00007f111dce1000)
libXau.so.6 => /usr/lib/libXau.so.6 (0x00007f111dcdc000)
libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0x00007f111dcd4000)
libpcre.so.1 => /usr/lib/libpcre.so.1 (0x00007f111dc62000)
```
This task depends upon

Closed by  Doug Newgard (Scimmia)
Tuesday, 25 August 2020, 01:58 GMT
Reason for closing:  Not a bug
Additional comments about closing:  /usr/lib/libreoffice/program/libfreetype .so.6 is not in the repos
Comment by HKKH (HKKH) - Monday, 24 August 2020, 20:38 GMT
After upgrading my system tonight(2020-08-25) I can't start it too. Only logo appears and then closed.
Even with `LD_PRELOAD=/usr/lib/libfreetype.so.6 libreoffice` I can't run it.
I have no output on console when I run it in terminal.

Even I downloaded appimage from libreoffice site but I can't run this standalone app too!

PLEASE HELP. I NEED IT FOR UNIVERSITY RESEARCH PAPER TOMORROW!!!
Comment by Evangelos Foutras (foutrelis) - Monday, 24 August 2020, 20:54 GMT
Where does "/usr/lib/libreoffice/program/libfreetype.so.6" in your ldd output come from?

Loading...